Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82487 - printer configuration crashes with python error
Summary: printer configuration crashes with python error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-22 17:51 UTC by Steve Witten
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-05 14:42:46 UTC


Attachments (Terms of Use)

Description Steve Witten 2003-01-22 17:51:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I was advised by RH Support to file this defect report...

As root...

Running 'printconf-gui' from a terminal yields:

Traceback (most recent call last):
  File "/usr/sbin/printconf-gui", line 7, in ?
    import printconf_gui
  File "/usr/share/printconf/util/printconf_gui.py", line 41, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 82, in ?
    from xml.utils import qp_xml
ImportError: No module named utils

Running 'redhat-config-printer-tui' from a terminal yields:

Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer-tui", line 7, in ?
    import printconf_tui
  File "/usr/share/printconf/util/printconf_tui.py", line 44, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 82, in ?
    from xml.utils import qp_xml
ImportError: No module named utils

At system bootup when the system tries to start lpd are as follows:

Traceback (most recent call last):
File "/usr/sbin/printconf-backend" line 7 in ?
  import printconf-backend
File "/usr/share/printconf/util/princonf_backend.py" line 29 in ?
File "/usr/share/printconf/util/printconf_conf.py" line 82 in ?
  from xml.utils import qp_xml
ImportError: no module named utils
No Printers Defined

Changing the printing system to CUPS eliminated the bootup messages but I still
can't configure printing.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See description.

Actual Results:  See description

Expected Results:  No error should be produced

Additional info:

Since I have no RHN until defect report 82483 gets repaired, I need a way to get
these fixes without RHN.  Also, see support ticket # 225471.

Comment 1 Tim Waugh 2003-01-22 18:01:13 UTC
Using the perl and python versions that came with the OS?  What's 'rpm -V perl
python' say?

(Incidentally, you can't use redhat-config-printer to configure CUPS, only LPRng.)


Note You need to log in before you can comment on or make changes to this bug.