Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82483 - up2date crashes with python error
Summary: up2date crashes with python error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Daniel Veillard
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-22 17:42 UTC by Steve Witten
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-23 16:48:26 UTC


Attachments (Terms of Use)

Description Steve Witten 2003-01-22 17:42:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:

I was advised by RH Support to file this defect report...

As root...

Running 'up2date --configure' yields:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 11, in ?
    import rpm
ImportError: No module named rpm

Running 'up2date --register' yields:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 11, in ?
    import rpm
ImportError: No module named rpm



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See description.

Actual Results:  See description.

Expected Results:  No error should be reported

Additional info:

Comment 1 Mihai Ibanescu 2003-01-22 17:50:37 UTC
What is
rpm -q rpm-python

returning?

Also, what version of Red Hat Linux are you using?

Comment 2 Steve Witten 2003-01-22 17:52:35 UTC
See RH Support ticket # 225471.  Since I have no RHN, I need a way to get these
fixes without RHN.

Comment 3 Steve Witten 2003-01-22 17:53:30 UTC
stevewi@sw722142:~ $ rpm -q rpm-python
rpm-python-4.0.4-7x.18


Comment 4 Steve Witten 2003-01-22 17:53:46 UTC
RH 8.0 Personal

Comment 5 Adrian Likins 2003-01-22 19:19:48 UTC
Whats the ouput of:

rpm -V rpm-python

and:

rpm -V up2date

also:

rpm -q rpm
rpm -V rpm


Haven't seen this error before, and since it looks pretty
serious right off the bat, I'm thinking there is something
wrong with your install (possibly rpm or rpm-python didn't
get installed somehow...). So going down that path first...

Comment 6 Steve Witten 2003-01-22 21:45:23 UTC
stevewi@sw722142:~ $ rpm -V rpm-python
Unsatisfied dependencies for rpm-python-4.0.4-7x.18: rpm = 4.0.4, popt = 1.6.4
stevewi@sw722142:~ $ rpm -V up2date
SM?....T c /etc/sysconfig/rhn/up2date
..?..... c /etc/sysconfig/rhn/up2date-keyring.gpg
SM5....T   /usr/share/rhn/up2date_client/config.pyc
stevewi@sw722142:~ $ rpm -q rpm
rpm-4.1-1.06
stevewi@sw722142:~ $ rpm -V rpm
....L...   /usr/lib/rpm/athlon-linux
....L...   /usr/lib/rpm/i386-linux
S.5.....   /usr/lib/rpm/i386-linux/macros
....L...   /usr/lib/rpm/i486-linux
....L...   /usr/lib/rpm/i586-linux
....L...   /usr/lib/rpm/i686-linux
....L...   /usr/lib/rpm/noarch-linux


Comment 7 Adrian Likins 2003-01-22 22:43:44 UTC
hmm:

stevewi@sw722142:~ $ rpm -q rpm-python
rpm-python-4.0.4-7x.18

Thats the wrong version of rpm-python. Thats a version
for the 7.x series. I missed that before.

Not sure how that version got on there, but you need

rpm-python-4.1-1.06.i386.rpm

You can get it from: 
ftp.redhat.com/pub/redhat/linux/8.0/en/i386/RedHat/RPMS/rpm-python-4.1-1.06.i386.rpm


Was this system an upgrade from a 7.x box? Something odd happened
at some point, and you got an older version of rpm-python installed. 



Comment 8 Steve Witten 2003-01-22 23:19:22 UTC
This was an upgrade from RH 7.3.  I installed the package you mention and all
seems to be right with up2date.  Thanks a lot.  BTW, I like the Bluecurve stuff
a lot...

Comment 9 Josef Komenda 2003-01-23 16:48:26 UTC
Fixed, closing. 


Note You need to log in before you can comment on or make changes to this bug.