Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82482 - daemon restart failure
Summary: daemon restart failure
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-22 17:27 UTC by Christopher McCrory
Modified: 2005-10-31 22:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-11 21:27:36 UTC


Attachments (Terms of Use)
output from up2date (deleted)
2003-01-22 23:35 UTC, Christopher McCrory
no flags Details
output of rpm -qa --last (deleted)
2003-01-28 17:34 UTC, Christopher McCrory
no flags Details

Description Christopher McCrory 2003-01-22 17:27:11 UTC
Description of problem:
running up2date from 8.0.92 to 8.0.93 
most updates went in alpha order.  When daemons were restarted ( I saw cups)
they would fail with:

Jan 21 15:03:05 office15 cups: cupsd shutdown succeeded
Jan 21 15:03:07 office15 cupsd: cupsd: error while loading shared libraries:
libssl.so.4: cannot open shared object file: No such file or directory
Jan 21 15:03:07 office15 cups: cupsd startup failed

This is because openssl gets updated later.

/sbin/init 1 ; /sbin/init 5 will fix all , but ...

Comment 1 Adrian Likins 2003-01-22 19:23:05 UTC
looks like a possible packaging bug with cups (or possible openssl), 
reassigning there...



Comment 2 Christopher McCrory 2003-01-22 19:41:26 UTC
I did this on a desktop machine so cups was the only affected daemon running
that came before the openssl update.  If I had been running apache , openldap,
etc.  they would probably have not restarted also.  Hence putting it under up2date.



Comment 3 Tim Waugh 2003-01-22 22:22:46 UTC
Adrian: what kind of packaging problem am I looking for?  cups requires
libssl.so.4 like it should.

Comment 4 Adrian Likins 2003-01-22 22:47:24 UTC
Hard to say. Maybe cups needs a PreReq on openssl? 

Looking at the scripts, I'm not exactly sure why the
init scripts would be getting tickled on an upgrade
either, unless `alternatives` is somehow doing it. 

Nothing else in the script's stands out as something
that should be troubleprone. I'll poke jbj and see
what his thought is. 




Comment 5 Jeff Johnson 2003-01-22 22:58:24 UTC
Hmmm, this might be a skipped (this is a feature, not a bug)
ldconfig that has not regenerated the symlink for a daemon
restart.

In order to tell, I'd need the ordered list of packages
for this up2date run so that I could see whether ldconfig
was run between openssl and cups package install. I'd need
to know the several packages before openssl was installed as well.

Comment 6 Adrian Likins 2003-01-22 23:27:49 UTC
Look in /var/log/up2date for a line similar to:

[Tue Jan 21 20:51:37 2003] up2date installing packages: ['kdeadmin-3.1-0.4',
'kdeutils-3.1-0.3', 'kdelibs-3.1-0.11', 'kdebase-3.1-0.14', 'ope
nssl-0.9.7-3', 'openssl096b-0.9.6b-1', 'lm_sensors-2.6.5-3',
'openssl-devel-0.9.7-3'] 

(except with the right date, and the packages you updated). This
should get some of the info jbj is looking for. 

Comment 7 Christopher McCrory 2003-01-22 23:29:51 UTC
I'll add a 'rpm -qa --last' if you want, but basically it was:
gdm-2.4.1.0-1
setup-2.5.23-1
[A-Z]* in alpha order
[a-z]* in alpha order
libgsf-1.6.0-3
qtcups-2.0-13

As if the "depends on this and that" step was done but ignored

ldconfig running or not wouldn't have mattered as /lib/libssl.so.0.9.7 was not
installed on the hard drive yet to symlink libssl.so.4 from.

yes? no? maybe?

Comment 8 Christopher McCrory 2003-01-22 23:35:35 UTC
Created attachment 89536 [details]
output from up2date

Comment 9 Jeff Johnson 2003-01-24 13:30:54 UTC
Hmmm, I need the ordering info. Can you append
    rpm -qa --last
here too? Thanks.

Comment 10 Christopher McCrory 2003-01-28 17:34:38 UTC
Created attachment 89649 [details]
output of rpm -qa --last

output of rpm -qa --last

IIRC:
up2date was hosed ( no versions showed up)
I tried rpm -Fvh redhat-release-8.0.93-2...
no go
rpm --rebuilddb (hung)
again (hung)
init 1
rpm --rebuilddb (go get coffee)
yea!
init 5
up2date

Comment 11 Jeff Johnson 2003-01-28 17:59:48 UTC
OK, this is not a missing ldconfig problem afaict.

BTW, all that's needed is
    rm -f /var/lib/rpm/__db*
you don't *have* to do --rebuilddb.

I suspect that your hangs are from doing "kill -9" too.

But, if you find the coffee pot empty, --rebuilddb -vv
will give you progress message sto watch

Comment 12 Tim Waugh 2003-01-29 09:28:38 UTC
CUPS clearly has the dependency listed for openssl.  I don't see how this can be
a packaging problem, unless I'm missing something.

Comment 13 Christopher McCrory 2004-01-11 21:27:36 UTC
Old


Note You need to log in before you can comment on or make changes to this bug.