Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 824802 - data lost when transfer from host to guest with virtio serial
Summary: data lost when transfer from host to guest with virtio serial
Keywords:
Status: CLOSED DUPLICATE of bug 677886
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-24 10:01 UTC by Suqin Huang
Modified: 2012-05-28 21:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-28 21:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Suqin Huang 2012-05-24 10:01:25 UTC
Description of problem:


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.293.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. cmd
-device virtio-serial-pci,id=virtio-serial-pci0 \

-chardev socket,path=/tmp/virtio-console-3XQGtS0,id=vs0,server,nowait \
-device virtserialport,chardev=vs0,name=serialport-0,id=serialport-0,bus=virtio-serial-pci0.0 \

-chardev socket,path=/tmp/virtio-console-3XQGtS1,id=vs1,server,nowait \
-device virtserialport,chardev=vs1,name=serialport-1,id=serialport-1,bus=virtio-serial-pci0.0

2. in host
# dd if=/dev/zero of=/root/file bs=1M count=1024 
# echo /root/file | nc -U /tmp/virtio-console-3XQGtS0

3. in guest
# cat /dev/virtio-ports/serialport-0 > bak
  
Actual results:
# md5sum bak 
4220a50fc53acd4abdea136bc42ec656  bak

# md5sum file 
cd573cfaace07e7949bc0c46028904ff  file

Expected results:


Additional info:

Comment 1 juzhang 2012-05-24 11:33:43 UTC
FYI, similar bugs
Bug 677886 - MD5 of file is different from the original one after transferred via virtio serial 
Bug 702611 - Some files were not integrated after transferring four files from host to guest

Comment 2 Ademar Reis 2012-05-28 21:24:53 UTC
Appears to be the same issue reported in Bug 677886. I've added your testcase there, so closing this as a dupe.

*** This bug has been marked as a duplicate of bug 677886 ***


Note You need to log in before you can comment on or make changes to this bug.