Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 824690 - RuntimeError: Error running ntfsresize: No such file or directory
Summary: RuntimeError: Error running ntfsresize: No such file or directory
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:719df1f09ee22196e3ab8dce902...
: 824745 (view as bug list)
Depends On:
Blocks: 839713
TreeView+ depends on / blocked
 
Reported: 2012-05-24 01:39 UTC by Xibo Ning
Modified: 2013-01-10 06:47 UTC (History)
2 users (show)

Fixed In Version: anaconda-17.28.2-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-04 12:49:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb-FPC8jp (deleted)
2012-05-24 01:39 UTC, Xibo Ning
no flags Details

Description Xibo Ning 2012-05-24 01:39:10 UTC
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-FPC8jp
hashmarkername: anaconda
kernel:         3.3.0-0.12.el7.x86_64
other involved packages: 
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Server release 7.0 Alpha1 (Maipo)
time:           Thu 24 May 2012 09:37:27 AM UTC
version:        7.0

anaconda-tb-FPC8jp: Text file, 171100 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.25 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 249, in execWithCapture
:    raise RuntimeError, "Error running " + command + ": " + e.strerror
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 1419, in minSize
:    stderr = "/dev/tty5")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 157, in __init__
:    foo = self.minSize      # force calculation of minimum size
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 88, in getFormat
:    fmt = fmt_class(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1659, in handleUdevDeviceFormat
:    device.format = formats.getFormat(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1050, in addUdevDevice
:    self.handleUdevDeviceFormat(info, device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1922, in _populate
:    self.addUdevDevice(dev)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1869, in populate
:    self._populate(progressWindow)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 480, in reset
:    cleanupOnly=cleanupOnly)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 102, in storageInitialize
:    storage.reset()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:RuntimeError: Error running ntfsresize: No such file or directory

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.xIN4WR
:LVM_SUPPRESS_FD_WARNINGS=1
:PWD=/
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1

Comment 1 Xibo Ning 2012-05-24 01:39:16 UTC
Created attachment 586504 [details]
File: anaconda-tb-FPC8jp

Comment 3 Jesse Keating 2012-05-24 06:41:57 UTC
*** Bug 824745 has been marked as a duplicate of this bug. ***

Comment 5 Jesse Keating 2012-05-24 17:51:34 UTC
Patch posted.

Comment 6 Jan Stodola 2012-07-04 12:49:52 UTC
Resizing of NTFS partitions is no longer allowed in anaconda, so I'm closing this bug as fixed.

Tested with anaconda-17.28.10-1.el7


Note You need to log in before you can comment on or make changes to this bug.