Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82461 - (xkb german) < > | key missing
Summary: (xkb german) < > | key missing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard: Defering for community approved solut...
Depends On:
Blocks: 79578 82770
TreeView+ depends on / blocked
 
Reported: 2003-01-22 14:17 UTC by Heinz Deinhart
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-07 20:17:40 UTC


Attachments (Terms of Use)

Description Heinz Deinhart 2003-01-22 14:18:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
this bug seems to be related to 79404
only with german keyboard layout

the '< > |' key does not work in X11
testet with: XFree86-4.2.99.3-20030115.0

patching /etc/X11/xkb/symbols/pc/de with this fixed it for me:
--- de	Sat Jan 18 15:30:27 2003
+++ de.fixed	Wed Jan 22 15:03:13 2003
@@ -8,6 +8,7 @@
     include "pc/latin(type4)"
 
     name[Group1]="German";
+    key <LSGT> {  [      less,    greater, bar ] };
 
     key <AE02>	{ [         2,   quotedbl,  twosuperior,    oneeighth ]	};
     key <AE03>	{ [         3,    section, threesuperior,    sterling ]	};


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
4.  

Additional info:

Comment 1 Mike A. Harris 2003-01-22 19:49:36 UTC
Please use bugzilla file attachment feature for adding patches, as cut and
pasting them destroys them.

Comment 2 Mike A. Harris 2003-01-23 23:36:28 UTC
I have forwarded this bug report, and cut and pasted patch upstream to
the xfree86@xfree86.org mailing list / bug report list, where it is awaiting
community feedback in order to ensure that this problem gets good peer
review and a correct fix is found.

Once the proper fix is determined by the XFree86 community, and checked
into the CVS repository, it will be included in a future build of XFree86
and made available for testing.  I will update this report at that time.

In the mean time, if you wish to further participate in seeking a
resolution to this issue, you may also wish to join the xfree86@xfree86.org
mailing list, and participate in developmental discussions concerning
xkb.

Defering for community approved solution.

Comment 3 Mike A. Harris 2003-01-31 02:27:26 UTC
This is believed to be fixed in the latest XFree86 CVS release.

Please test XFree86-4.2.99.4-20030129.1 from rawhide, and close this
report as RAWHIDE if it now works.  Otherwise please change to ASSIGNED
and report the problem to xfree86@xfree86.org to ensure they fix it before
XFree86 4.3.0 is released.

Thanks.

Comment 4 Jay Turner 2003-02-07 20:17:40 UTC
Fix confirmed with XFree86-4.2.99.901-20030203.1.


Note You need to log in before you can comment on or make changes to this bug.