Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82453 - boot arg netprofile does not work
Summary: boot arg netprofile does not work
Keywords:
Status: CLOSED DUPLICATE of bug 79171
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 80194
TreeView+ depends on / blocked
 
Reported: 2003-01-22 10:53 UTC by Harald Hoyer
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:18 UTC


Attachments (Terms of Use)

Description Harald Hoyer 2003-01-22 10:53:41 UTC
netprofile=PROFILE doesn't work because there is a bug in the script
/etc/rc.d/rc.sysinit :

# Boot time profiles. Yes, this should be somewhere else.
if grep -q "netprofile=" /proc/cmdline ; then
    cmdline=`cat /proc/cmdline`
    for arg in cmdline ; do                           
       if [ "${arg##netprofile=}" != "${arg}" ]; then
          [ -x /usr/sbin/redhat-config-network-cmd ] &&
            /usr/sbin/redhat-config-network-cmd --profile ${arg##netprofile=}
       fi
    done
fi

==> the line for arg in cmdline ; do
should be for arg in $cmdline ; do

Comment 1 Bill Nottingham 2003-01-22 21:21:55 UTC

*** This bug has been marked as a duplicate of 72903 ***

Comment 2 Harald Hoyer 2003-01-23 10:12:47 UTC
huh? the duplicate does not seem to be the right one...

Comment 3 Bill Nottingham 2003-01-23 22:54:34 UTC
Woops.

Comment 4 Bill Nottingham 2003-01-23 22:55:09 UTC

*** This bug has been marked as a duplicate of 79171 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:51:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.