Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 824495 - ipactl.service fails on boot - but not if manually started
Summary: ipactl.service fails on boot - but not if manually started
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On: 806424
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-23 15:30 UTC by Dmitri Pal
Modified: 2013-11-29 11:11 UTC (History)
7 users (show)

Fixed In Version: ipa-3.3.3-5.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 806424
Environment:
Last Closed: 2013-11-29 11:10:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dmitri Pal 2012-05-23 15:30:00 UTC
+++ This bug was initially created as a clone of Bug #806424 +++

Description of problem:

The ipactl.service fails on boot, but not if it is subsequently restarted manually on boot up



Version-Release number of selected component (if applicable):
freeipa-server-2.1.4-5.fc16.x86_64

How reproducible:
Installed freeipa as per the instructions on the Fedora web site and ipactl.service always fails on boot up but not if restarted manually

Steps to Reproduce:
1.
2.
3.
  
Actual results:

It should start up

Expected results:

It does not start

Additional info:

I've worked around this by doing a systemctl enable dirsrv.target and now the ipactl.service does start on boot. What "seems" to happen is that ipactl starts the 389 directory server but as far as systemd is concerned that target (dirsrv.target) isn't wanted so it immediately shuts it down. Then the subsequent services that ipactl tries to start fail because they can't contact the 389 directory service. By explicitly enabling the dirsrv.target - it does not get shutdown by systemd.

With systemd supposedly being all singing - all dancing - is ipactl the correct thing to do - or should it be properly converted so that systemd itself starts the required services? At the very least it would appear the ipactl.service may need a dependency on dirsrv.target adding.

Comment 2 Martin Kosek 2013-11-29 11:10:41 UTC
This is known to work in current RHEL-7.0 version, upstream version was also closed some time ago. Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.