Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 824303 - Broken symlink for python-config in python-devel
Summary: Broken symlink for python-config in python-devel
Keywords:
Status: CLOSED DUPLICATE of bug 813836
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 824426 825519
TreeView+ depends on / blocked
 
Reported: 2012-05-23 08:41 UTC by Simone Caronni
Modified: 2012-05-29 15:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-29 15:24:43 UTC


Attachments (Terms of Use)

Description Simone Caronni 2012-05-23 08:41:59 UTC
Description of problem:
Package python-devel in Fedora 16 ships with a broken symlink that breaks all python detections relying on "/usr/bin/python-config"

Version-Release number of selected component (if applicable):
python-devel-2.7.3-1.fc16.x86_64

How reproducible:
Install python-devel, and run "/usr/bin/python-config --includes"

Steps to Reproduce:
1. Install python-devel
2. Run "/usr/bin/python-config --includes"
3. Run "ls -al /usr/bin/python*"
  
Actual results:
$ usr/bin/python-config --includes
bash: /usr/bin/python-config: No such file or directory
$ ls -al /usr/bin/python*
lrwxrwxrwx. 1 root root    7 May 23 10:09 python -> python2
lrwxrwxrwx. 1 root root    9 May 23 10:09 python2 -> python2.7
-rwxr-xr-x. 1 root root 4896 Apr 13 22:17 python2.7
-rwxr-xr-x. 1 root root 1785 Apr 13 22:17 python2.7-config
lrwxrwxrwx. 1 root root   14 May 23 10:11 python-config -> python2-config

Expected results:
$ /usr/bin/python-config --includes
-I/usr/include/python2.7 -I/usr/include/python2.7
$ ls -al /usr/bin/python*
lrwxrwxrwx. 1 root root    7 May  9 13:33 python -> python2
lrwxrwxrwx. 1 root root    9 May  9 13:33 python2 -> python2.7
-rwxr-xr-x. 1 root root 6184 Apr 30 23:18 python2.7
-rwxr-xr-x. 1 root root 1785 Apr 30 23:18 python2.7-config
lrwxrwxrwx. 1 root root   16 May 23 10:16 python2-config -> python2.7-config
lrwxrwxrwx. 1 root root   14 May 23 10:16 python-config -> python2-config


Additional info:
This only happens in Fedora 16; Fedora 15, 17 and rawhide are ok.
You can see through koji builds that Fedora 16 misses the "python2-config -> python2.7-config" symlink.

Comment 1 Jan Safranek 2012-05-23 10:37:55 UTC
It breaks wireshark build on F16: https://koji.fedoraproject.org/koji/getfile?taskID=4095828&name=build.log

Comment 3 Juan 2012-05-28 23:20:36 UTC
I noticed this while building a custom kernel.
It disable python support when building kernel tools.

Comment 4 Dave Malcolm 2012-05-29 15:24:43 UTC
This is a duplicate of bug 813836; looks like the fix never made it to F16.  Sorry about that.

Building python-2.7.3-3.fc16 for f16-candidate
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=4112248

*** This bug has been marked as a duplicate of bug 813836 ***


Note You need to log in before you can comment on or make changes to this bug.