Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82426 - aspell 0.33 hangs on large xml documents
Summary: aspell 0.33 hangs on large xml documents
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aspell
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-22 01:06 UTC by Judd Rogers
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 21:37:01 UTC


Attachments (Terms of Use)

Description Judd Rogers 2003-01-22 01:06:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
Redhat 8.0 ships with
aspell --version
@(#) International Ispell Version 3.1.20 (but really Aspell .33.7.1 alpha)
rpm -q aspell
aspell-0.33.7.1-16

If I run this version against large xml documents (DocBook DTD), aspell consumes
all memory and cpu but never displays any spelling errors.

So I downloaded the newest version, built it and installed it. Problem solved.

Time for y'all to step up. :-)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
spell check a big xml file.    

Actual Results:  most of memory consumed 
all of cpu consumed

Expected Results:  spell checking dialog should appear on console

Additional info:

Sorry, Can't send you the xml. Confidential.

Comment 1 Eido Inoue 2003-02-19 21:37:01 UTC
aspell will be upgraded with the next release


Note You need to log in before you can comment on or make changes to this bug.