Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82417 - Internal compiler error
Summary: Internal compiler error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 23:15 UTC by Kevin Van Maren
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 12:00:46 UTC


Attachments (Terms of Use)

Description Kevin Van Maren 2003-01-21 23:15:22 UTC
Description of problem:

Compiling Linux 2.5.52 w/IA64 patches I get:
arch/ia64/kernel/perfmon.c:1617: Internal compiler error in rws_access_regno, 
at config/ia64/ia64.c:3701

Version-Release number of selected component (if applicable):
gcc-2.96-85

How reproducible:

Compile a new kernel.

Steps to Reproduce:
1. compile 2.5.52 w/perfmon (under Processor) support on RH7.1/IA64
2.
3.
    
Actual results:

Compiler failure

Expected results:

Object file

Additional info:

make -f scripts/Makefile.build obj=arch/ia64/kernel
  gcc -Wp,-MD,arch/ia64/kernel/.perfmon.o.d -D__KERNEL__ -Iinclude -Wall -
Wstrict-prototypes -Wno-trigraphs -
g -O2 -fno-strict-aliasing -fno-common -pipe  -ffixed-r13 -mfixed-range=f10-
f15,f32-f127 -falign-functions=32
 -fomit-frame-pointer -nostdinc -iwithprefix include -mconstant-gp   -
DKBUILD_BASENAME=perfmon -DKBUILD_MODNA
ME=perfmon   -c -o arch/ia64/kernel/perfmon.o arch/ia64/kernel/perfmon.c
arch/ia64/kernel/perfmon.c: In function `pfm_read_pmds':
arch/ia64/kernel/perfmon.c:1617: Internal compiler error in rws_access_regno, 
at config/ia64/ia64.c:3701
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [arch/ia64/kernel/perfmon.o] Error 2
make: *** [arch/ia64/kernel] Error 2

Comment 1 Richard Henderson 2004-10-03 12:00:46 UTC
Perfmon has been built since then.


Note You need to log in before you can comment on or make changes to this bug.