Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 824087 - [RFE] katello-upgrade should take care of stopping and starting services
Summary: [RFE] katello-upgrade should take care of stopping and starting services
Keywords:
Status: CLOSED DUPLICATE of bug 820280
Alias: None
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: SAM QE List
URL:
Whiteboard:
Depends On:
Blocks: sam11-tracker
TreeView+ depends on / blocked
 
Reported: 2012-05-22 17:20 UTC by Tom McKay
Modified: 2012-06-19 14:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 820621
Environment:
Last Closed: 2012-05-22 17:22:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Tom McKay 2012-05-22 17:20:27 UTC
+++ This bug was initially created as a clone of Bug #820621 +++

+++ This bug was initially created as a clone of Bug #820280 +++

Description of problem:
During the upgrade process the first step is to shutdown services.  The katello-upgrade script should handle this, taking this step out of the hands of the sysadmin makes the script more userfriendly.


Steps to Reproduce:
1. katello-upgrade
2. You are about to shutdown katello services and upgrade, Continue[y|N]?
3. Y

  
Actual results:
All required katello services (tomcat6, thumbslug, katello-jobs, katello etc..) would be stopped by the script and the upgrade would continue.

Comment 1 Tom McKay 2012-05-22 17:22:30 UTC

*** This bug has been marked as a duplicate of bug 820280 ***


Note You need to log in before you can comment on or make changes to this bug.