Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82396 - microcode_ctl fails on NFS-based system
Summary: microcode_ctl fails on NFS-based system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 85574 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 20:37 UTC by Oliver Scheck
Modified: 2015-01-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-01-18 20:52:37 UTC


Attachments (Terms of Use)

Description Oliver Scheck 2003-01-21 20:38:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2) Gecko/20021203

Description of problem:
microcode_ctl fails on NFS-based system because it uses /usr/bin/head
which is not available at that time:
in the standard install for runlevel 3 microcode_ctl is executed as
S00microcode_ctl before /usr is mounted via S25netfs.

Solution:
* Either execute microcode_ctl after NFS mount e.g. S30microcode_ctl or
* use /bin/awk instead of /usr/bin/head.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Setup NFS-based system where /usr is mounted from an NFS server.
2. Install kernel-utils (contains microcode_ctl) and activate microcode_ctl for
runlevel 3.
3. Boot the system.
    

Actual Results:  microcode_ctl fails with "No such file or directory:
/usr/bin/head".

Expected Results:  Successful execution of microcode_ctl.

Additional info:

Comment 1 Dave Jones 2004-10-26 03:13:04 UTC
*** Bug 85574 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2004-11-28 21:12:39 UTC
fixed in cvs.


Comment 3 Dave Jones 2005-01-18 20:52:37 UTC
went out into updates-testing today, will go to live updates real soon.



Note You need to log in before you can comment on or make changes to this bug.