Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82384 - setting up /etc/ntp.conf before firstboot runs breaks date and time module
Summary: setting up /etc/ntp.conf before firstboot runs breaks date and time module
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 20:04 UTC by Alexandre Oliva
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:17 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2003-01-21 20:04:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Running local configuration scripts at the end of kickstart or in single-user
mode, that modify /etc/ntp.conf, before firstboot runs can be fatal for the Date
and Time module.  Here's what my scripts append to the default /etc/ntp.conf:

# @AH_BEGIN:xntp.client:-rw-r-----    1 root     root          330 Aug 19 14:36
xntp.client@
broadcastclient
 
restrict 172.31.160.14 nomodify notrap
restrict 143.106.24.189 nomodify notrap
restrict 143.106.24.129 nomodify notrap
restrict 172.31.160.16 nomodify notrap
 
server 172.31.160.14 # fri
server 143.106.24.189 # fri-external
server 143.106.24.129 # emilia
server 172.31.160.16 # emilia-cipe
# @AH_END:xntp.client@

If I add this to /etc/ntp.conf and re-enable firstboot, the crash occurs just
the same.  The top of the anaconda stack trace is:

/usr/share/redhat-config-date/date_gui.py, line 171, in __init__:
  ntpServer = socket.gethostbyaddr(ntpServerIp)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None.

Version-Release number of selected component (if applicable):
phoebe2

How reproducible:
Always

Steps to Reproduce:
1.Add the lines above to /etc/ntp.conf
2.Let firstboot run

Actual Results:  The exception above.

Expected Results:  Should work, no?

Additional info:

Comment 1 Alexandre Oliva 2003-01-21 22:34:20 UTC
Erhm.   I tried an install from scratch, without kickstart and without running
my scripts at first, and it failed just the same, so it has nothing to do with
my settings.

Comment 2 Brent Fox 2003-01-21 23:08:53 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.