Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82379 - Applet handles in kicker make it not consistent across desktops (aka diferent from Gnome panel)
Summary: Applet handles in kicker make it not consistent across desktops (aka diferent...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase
Version: phoebe
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 19:30 UTC by Carlos Woelz
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-22 23:46:19 UTC


Attachments (Terms of Use)
This is before - JPEG (deleted)
2003-01-22 03:12 UTC, Carlos Woelz
no flags Details
After: hidden JPEG (deleted)
2003-01-22 03:15 UTC, Carlos Woelz
no flags Details
JPEG (deleted)
2003-01-22 03:36 UTC, Carlos Woelz
no flags Details

Description Carlos Woelz 2003-01-21 19:30:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20030119
Phoenix/0.5 (In my office... You can see I did not yet convince people to move
to linux...)

Description of problem:
Since null, the first thing I do after instaling a new HR is to autohide the
applet handles in kicker for a consistent look for KDE and Gnome. This was (in
KDE 3.0x) a "hidden" option (one had to edit the kickerrc). But now it is a GUI
configurable option, making this easy to select/unselect.

This is a step foward in the direction of making a more consistent looking desktop. 

Also, in my opinion, the handles with Bluecurve look ugly, because the main
feature and characteristic of Bluecurve are its clean look, with improves
usability. The handles ere obtrusive.

Version-Release number of selected component (if applicable):



How reproducible:
Always

Steps to Reproduce:
1.Log on KDE
2.
3.
    

Actual Results:  Kicker shows with visible applet handles

Expected Results:  Kicker shows with autohidden applet handles

Additional info:

Since there is a obvius effort to make Gnome and KDE consistent, there is no
reason to make them look distinct, when no functions are lost.

Comment 1 Havoc Pennington 2003-01-21 23:19:21 UTC
Does KDE really support turning the handles off? e.g. is there a way to get 
all the same stuff from a right-click menu?

Comment 2 Carlos Woelz 2003-01-22 00:06:33 UTC
Truth is, You may not remove the handles, but make them autohide until you hover
the mouse over it. This is an option since 3.0x, but it is configurable in
Kconfig since 3.1. (So it is easier to revert if someone likes it differently...)

To see this effect (without using the gui, so you may do it in null/KDE 3.0x), add 
FadeOutAppletHandles=true to the kickerrc

Anyway, when I get home I will send you some litle bitmaps to show you what I mean.

Comment 3 Carlos Woelz 2003-01-22 03:12:10 UTC
Created attachment 89502 [details]
This is before - JPEG

The handle: you know it already

Comment 4 Carlos Woelz 2003-01-22 03:15:36 UTC
Created attachment 89503 [details]
After: hidden JPEG

All positions are the same, but the handle is in Autohide mode.
Hover over it and it will show.

Comment 5 Carlos Woelz 2003-01-22 03:36:41 UTC
Created attachment 89504 [details]
JPEG

Sorry, I am struggling with bugzilla a bit...
This is the correct JPEG after.

Comment 6 Carlos Woelz 2003-01-22 15:06:55 UTC
BTW, setting the clock in the panel without the shadow is also easy and more
consistent with the gnome clock.

Comment 7 Carlos Woelz 2003-01-23 12:56:59 UTC
Oh, I forgot to answer your question.

No, you cannot get the same stuff by a right click. You have to keep the handles.

Comment 8 Havoc Pennington 2003-01-23 15:09:47 UTC
It seems to me that "invisible buttons" are not a good default; right-click 
is at least a fairly well-known convention. I think we should keep the handles.

Comment 9 Ngo Than 2003-02-22 23:46:19 UTC
i presume, we don't want to have autohidden applet handles as default setting.
So i close it as wontfix.


Note You need to log in before you can comment on or make changes to this bug.