Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82363 - "pkg-config --libs blah" prints /usr/lib64 on Hammer
Summary: "pkg-config --libs blah" prints /usr/lib64 on Hammer
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pkgconfig
Version: 1.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-21 17:15 UTC by Joe Orton
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-25 04:21:19 UTC


Attachments (Terms of Use)

Description Joe Orton 2003-01-21 17:15:49 UTC
Description of problem:
"pkg-config --libs" output should not include /usr/lib64 on Hammer.

Version-Release number of selected component (if applicable):
pkgconfig-0.14.0-1

How reproducible:
Always

Steps to Reproduce:
e.g.
$ pkg-config --libs libxml-2.0
   
Actual results:
-L/usr/lib64 -lxml2 -lz -lm

Expected results:
 -lxml2 -lz -lm

Additional info:
A simple and probably naive fix is to pass the expansion of ${libdir} into
config.h, and check against that in pkg.c rather than the hard-coded "/usr/lib".

Comment 1 Havoc Pennington 2003-01-21 17:19:47 UTC
Can you remind me why it removes -L/usr/lib? (I don't remember the impact of
this issue.)

Comment 2 Joe Orton 2003-01-21 17:25:00 UTC
I think just because it changes the order the library search path unnecessarily:
so if I have "-L/usr/lib64 -L/home/joe/lib -lfoobar" then I might *want* to pick
up -lfoobar out of /home/joe/lib but the /usr/lib64 means I pick up the system
copy instead, if there is one.  It's not a big issue anyway.

Comment 3 Jeremy Katz 2003-02-25 04:21:19 UTC
Nalin fixed this in 0.14.0-3


Note You need to log in before you can comment on or make changes to this bug.