Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82340 - NTP does not query the time server frequently enough to prevent drift
Summary: NTP does not query the time server frequently enough to prevent drift
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 14:33 UTC by Michael Lee Yohe
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 16:59:13 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2003-01-21 14:33:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030102

Description of problem:
My system generally gains two minutes in a week period.  This system has been
running non-stop for two weeks now, and was four minutes fast.  I have
configured NTP (using redhat-config-date) so that it would query the time server
for updates to keep the clock syncronized.  I have noticed that it had not
queried at all during the two week period.  Upon running redhat-config-date
again, it manually checked the time server and then corrected the time drift.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description
    

Actual Results:  Clock drifts fast...

Expected Results:  Clock should stay in sync with nightly queries to the time
server.

Additional info:

$ rpm -q ntp
ntp-4.1.1a-9

Comment 1 Harald Hoyer 2003-01-21 16:15:17 UTC
what does ntpdc say?

# /usr/sbin/ntpdc
ntpdc> peers
     remote           local      st poll reach  delay   offset    disp
=======================================================================
....

Comment 2 Michael Lee Yohe 2003-01-21 16:53:07 UTC
$ /usr/sbin/ntpdc 
ntpdc> peers
     remote           local      st poll reach  delay   offset    disp
=======================================================================
=time.nist.gov   5.0.0.0         16  512    0 0.00000  0.000000 0.00000


Comment 3 Harald Hoyer 2003-01-21 16:59:13 UTC
so it does not connect... your /etc/ntp.conf should look like:

restrict default ignore
restrict 192.43.244.18 mask 255.255.255.255 nomodify notrap noquery
restrict 127.0.0.1
driftfile /etc/ntp/drift
broadcastdelay 0.008
authenticate yes
keys /etc/ntp/keys
server 192.43.244.18


Comment 4 Michael Lee Yohe 2003-01-21 17:09:05 UTC
Okay - then perhaps this bug needs to be Component == redhat-config-date.  When
I configured ntp at installation, I expected it to query the server once in a
while.  This default configuration apparently does not query the server due to
an initial configuration issue.

The period by which an update can be made should be configurable by
redhat-config-date.


Note You need to log in before you can comment on or make changes to this bug.