Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 823270 - grubby --default-kernel segfault as user
Summary: grubby --default-kernel segfault as user
Keywords:
Status: CLOSED DUPLICATE of bug 751608
Alias: None
Product: Fedora
Classification: Fedora
Component: grubby
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-20 13:01 UTC by Nicolas Chauvet (kwizart)
Modified: 2012-08-31 14:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-31 14:51:55 UTC


Attachments (Terms of Use)
grubby --default-kernel segault when run as user (deleted)
2012-05-20 13:01 UTC, Nicolas Chauvet (kwizart)
no flags Details

Description Nicolas Chauvet (kwizart) 2012-05-20 13:01:12 UTC
Created attachment 585639 [details]
grubby --default-kernel segault when run as user

Description of problem:
grubby --default-kernel segfault when run as non privileged users.
Even if it's not supposed to do so, the command should return insufficient privilege but not to segfault. 

Version-Release number of selected component (if applicable):
grubby-8.11-1.fc17

How reproducible:
always from two different setup running f17 (i686 and x86_64).

Steps to Reproduce:
1.$ grubby --default-kernel

  
Actual results:
grubby recieved SIGSEGV!  Backtrace (6):
grubby[0x40525f]
/lib64/libc.so.6[0x38ffc359e0]
grubby[0x401bc9]
grubby[0x404232]
/lib64/libc.so.6(__libc_start_main+0xf5)[0x38ffc21735]
grubby[0x404691]

Expected results:
return an error code or the default kernel

Additional info:
When run as root (as probably expected) the right kernel is output in one of theses setup. (then there is another bug as #736188 for the other).
# grubby --default-kernel
/boot/vmlinuz-3.3.4-5.fc17.x86_64

Comment 1 Andrew Elwell 2012-08-31 14:51:55 UTC

*** This bug has been marked as a duplicate of bug 751608 ***


Note You need to log in before you can comment on or make changes to this bug.