Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82323 - trivial typo prevents boot-time selection of network profile
Summary: trivial typo prevents boot-time selection of network profile
Keywords:
Status: CLOSED DUPLICATE of bug 79203
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 09:56 UTC by Ben Liblit
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-17 05:49:21 UTC


Attachments (Terms of Use)
fix: add "$" for proper variable expansion (deleted)
2003-01-21 10:01 UTC, Ben Liblit
no flags Details | Diff

Description Ben Liblit 2003-01-21 09:56:55 UTC
Description of problem:

One is supposed to be able to put "netprofile=<foo>" on the kernel command line
to select network profile <foo> when booting.  However, a trivial typo in
"/etc/rc.d/rc.sysinit" 

Version-Release number of selected component (if applicable):

initscripts-6.95-1

How reproducible:

Easily, every time.

Steps to Reproduce:
1. Create at least two network profiles using "neat".
2. Using GRUB or LILO, add "netprofile=foo" to the kernel command line,
replacing "foo" with the name of one of the network profiles.
3. Boot.
    
Actual results:

Named network profile is not activated.

Expected results:

Named network profile should have been activated.

Additional info:

The bug is on line 766 of "/etc/rc.d/rc.sysinit", where a loop iterates over
"cmdline" instead of "$cmdline".  I will attach a diffs to this report showing
the correction.

Comment 1 Ben Liblit 2003-01-21 10:01:13 UTC
Created attachment 89456 [details]
fix: add "$" for proper variable expansion

Comment 2 Bill Nottingham 2003-01-21 17:20:03 UTC

*** This bug has been marked as a duplicate of 79203 ***

Comment 3 Ben Liblit 2004-08-17 05:49:21 UTC
Marking as CLOSED: the duplicate designation is correct, and
furthermore the bug has long since been fixed.


Note You need to log in before you can comment on or make changes to this bug.