Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82304 - Redhat_Config_network crashes when attempting changes
Summary: Redhat_Config_network crashes when attempting changes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 03:47 UTC by Keith Hornbaker
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-05 14:19:19 UTC


Attachments (Terms of Use)

Description Keith Hornbaker 2003-01-21 03:47:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have two nic cards installed eth0=RealTek RTL-8139 SMC and eth1=AMD PCNET32.
eth0 is configured for DSL at 100mhz. eth1 is connected to a 10mhz local lan
using a static ip. Both cards were detected and installed correctly during the
installation, following installation both cards operated correctly. When Samba
didn't work a typo was discovered in the host name. Tried to fix the typo in X
with the Redhat Config tool which on the first attempt appeared to work, but
after a reboot found eth0 had been assigned the static ip of eth1 and eth1 was
inactive. Tried to set things back the way they were in X using the redhat
config tool but started having the network config program crashing and making no
updates (saved a copy of the dump file). The only way I could get eth0
configured for dsl again was to use ifconfig which the config tool now 
recognizes. I reconfigured eth1 with ifconfig but the config tool still sees it
as inactive after a reboot.   

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Setup system with multiple nic cards
2.Change host name with config tool 
3.Reboot
    

Actual Results:  Network configuration changed on eth0 (static ip of eth1
assigned) and eth1 was made inactive

Expected Results:  System updated with new host name

Additional info:

Comment 1 Harald Hoyer 2003-01-30 12:45:39 UTC
please attach the dump file

Comment 2 Adrian Bright 2003-10-15 12:51:33 UTC
I've got the same kind of thing, but this crashes when any change at all made 
when you try and save. This is under 7.2 with ver 0.9.10-2. Is there any 
prospect of a fix for a 7.2 network-config, or is it best just to try upgrading 
to 9.

Eg below:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 401, in on_okButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 270, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 278, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py", 
line 121, in save
    papconf = getPAPConf()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NC_functions.py", 
line 91, in getPAPConf
    DVpapconf = ConfPAP.ConfPAP("/etc/ppp/pap-secrets")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfPAP.py", line 
30, in __init__
    Conf.Conf.__init__(self, filename, '#', ' \t', ' \t')
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 180, 
in __init__
    self.read()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfPAP.py", line 
35, in read
    self.initvars()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfPAP.py", line 
74, in initvars
    var = self.getfields()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ConfPAP.py", line 
100, in getfields
    if len(var[2]) and var[2][0] in '\'"':
IndexError: list index out of range

Local variables in innermost frame:
self: <netconfpkg.ConfPAP.ConfPAP instance at 84a7b00>
var: ['nameserver', '217.148.40.6']


Comment 3 Harald Hoyer 2003-10-15 13:24:14 UTC
please file a seperate bugzilla entry for the last report


Note You need to log in before you can comment on or make changes to this bug.