Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82297 - firstboot "error occurred in the Date & TIme module"
Summary: firstboot "error occurred in the Date & TIme module"
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 02:55 UTC by Gerry Tool
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:16 UTC


Attachments (Terms of Use)

Description Gerry Tool 2003-01-21 02:55:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
On firstboot, got a message dialog that said "An error has occurred in the Date
& Time module".  Listed traceback and stated I should file a bug against firstboot.

Traceback from file in /root shown in Additional Information below.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Start up Phoebe 2 first time
2.Error dialog appears
3.
    

Actual Results:  Error dialog about Date and Time module appeared

Expected Results:  Normal firststart process

Additional info:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

Comment 1 louisgtwo 2003-01-21 04:24:31 UTC
I got this to after installing from hard drive partition.

Comment 2 petrosyan 2003-01-21 04:29:52 UTC
I got that after installing from CDs

Comment 3 Bill Nottingham 2003-01-21 04:47:22 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.