Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82296 - MainMan issues ValueError: math domain error in cronjob
Summary: MainMan issues ValueError: math domain error in cronjob
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailman
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-21 02:33 UTC by Mark Cooke
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-02-14 20:59:50 UTC


Attachments (Terms of Use)

Description Mark Cooke 2003-01-21 02:33:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
I have set up mailman for a small low volume mailing list, the list is working
fine (from what I can see), but every night I get the following in my crontab
for mailman:

Traceback (most recent call last):
  File "/var/mailman/cron/gate_news", line 40, in ?
    from Mailman import MailList
  File "/var/mailman/Mailman/MailList.py", line 36, in ?
    from Mailman import Utils
  File "/var/mailman/Mailman/Utils.py", line 32, in ?
    import random
  File "/usr/lib/python2.2/random.py", line 91, in ?
    NV_MAGICCONST = 4 * _exp(-0.5)/_sqrt(2.0)
ValueError: math domain error



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. let default cronjob frun for mailman
2.
3.
    

Actual Results:  see above

Expected Results:  Don't know, it has always done this (sorry)

Additional info:

Comment 1 Mark Cooke 2003-01-21 02:34:06 UTC
This is also present in the cron job as well:

Traceback (most recent call last):
  File "/var/mailman/cron/qrunner", line 84, in ?
    from Mailman import Utils
  File "/var/mailman/Mailman/Utils.py", line 32, in ?
    import random
  File "/usr/lib/python2.2/random.py", line 91, in ?
    NV_MAGICCONST = 4 * _exp(-0.5)/_sqrt(2.0)
ValueError: math domain error

Comment 2 John Dennis 2003-01-27 21:55:30 UTC
This is a bit odd, I don't think this has anything to do with mailman per se.
The problem would appear to be in your python installation. The line of code
producing the error in random.py looks just fine, it shouldn't be generating an
error. I'm running python 2.2.1. I don't get this error and so far to the best
of my knowledge no one has reported a similar problem in the mailmain
discussions lists.

As a sanity check please try the following, start an interactive python session
by typing python at the command line, then type this:

import random

do you get any errors?

then type this:

random.NV_MAGICCONST

do you get something close in value to this?

1.7155277699214135




Comment 3 Mark Cooke 2003-01-28 18:23:32 UTC
typing the the above did not produce any errors at all.

I have since upgraded to mailman-2.1 (updated the official redhat rpm) and that
still producs the error on 
'/var/mailman/cron/gate_news', but qrunnner now works perfectly.

I removed all traces of the updated mailman (v 2.1) and reinstalled the supplied
mailman from RH 8 and that still produces the same two errors.

Mark

Comment 4 Florian La Roche 2004-06-06 09:56:35 UTC
Is this still happening with a current mailman package?

Thanks,

Florian La Roche


Comment 5 John Dennis 2005-02-14 20:59:50 UTC
Closing this out because no one else has reported the problem and I
can't reproduce it.


Note You need to log in before you can comment on or make changes to this bug.