Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 822951 - Relax restrictions on key names
Summary: Relax restrictions on key names
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OKD
Classification: Red Hat
Component: Master
Version: 2.x
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: ---
Assignee: Ravi Sankar
QA Contact: libra bugs
URL:
Whiteboard:
: 794506 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-18 15:29 UTC by Clayton Coleman
Modified: 2015-05-15 00:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-16 19:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Clayton Coleman 2012-05-18 15:29:03 UTC
Dan and I had a long discussion about the ideal experience for keys.  What we "want" for users is for them to be able to give each key a unique name that is fairly recognizable.  The limitations on key name are too restrictive at this point because you cannot use spaces, dashes, or underscores (all valid filesystem characters) to distinguish your names.

I suggest we allow the following range of characters

  the majority of unicode "word" letters (i.e. other character sets)
  numbers
  underscores
  dashes
  spaces
  left and right brackets
  left and right parenthesis
  left and right curly braces

Clients are responsible for serializing and deserializing these to the filesystem.  Backends should not use the exact key name on disk (should sanitize).

Comment 1 Ravi Sankar 2012-06-29 21:38:22 UTC
Currently we are testing our broker code on ruby-1.8 and ruby 1.8 version DOESN'T have full support for character encoding. Only Regex engine has UTF-8 support and we can work around using 'jcode' ruby library[1]. But the ruby 1.9 version has support for character encoding and it may not be worth solving this issue on ruby 1.8 version. 
  We already have a user story [US2368] to move current broker code to Ruby 1.9 and Rails 3.2. Once this story is completed, we can tackle this issue.

Reference:
[1] http://blog.grayproductions.net/articles/understanding_m17n

Comment 2 Ravi Sankar 2012-07-04 00:03:50 UTC
*** Bug 794506 has been marked as a duplicate of this bug. ***

Comment 3 Mike McGrath 2012-10-10 18:41:49 UTC
Please convert this to a story so we can prioritize it in the backlkog.  Once the story is created, please close this bug with the US number.

 - Bug Triage Meeting

Comment 4 Ravi Sankar 2012-10-16 19:52:10 UTC
Created US3026 to address this issue.


Note You need to log in before you can comment on or make changes to this bug.