Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82288 - non-ascii broken in some gdm texts
Summary: non-ascii broken in some gdm texts
Keywords:
Status: CLOSED DUPLICATE of bug 82168
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-20 22:17 UTC by Daniel Resare
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:16 UTC


Attachments (Terms of Use)

Description Daniel Resare 2003-01-20 22:17:55 UTC
Description of problem:

When I set the system language to swedish (sv_SE.UTF-8) some translated messages
on the login screen have broken non-ascii characters. More specifically the
UTF-8 string from the translations file is treated as an ISO-8859-1 string and
what should have been an å is now displayed as two bogus characters.

This does not apply to all texts in the gdm screen. The translation to 'Please
enter your username' gets translated correctly. 'Welcome to $HOST' and
'Language' are broken.

Version-Release number of selected component (if applicable):
gdm-2.4.1.0-1 (phoebe 8.0.93)

How reproducible:
seems to be always.

Steps to Reproduce:
1. Set system language to Swedish
2. Log out

    
Actual results:
borken ä ö and å in some texts on the gdm login screen

Expected results:
properly recognized non-ascii

Additional info:

Comment 1 Havoc Pennington 2003-01-20 23:10:21 UTC

*** This bug has been marked as a duplicate of 82168 ***

Comment 2 Daniel Resare 2003-01-21 00:02:57 UTC
Please make #8168 a duplicate of this bug instead, or move that bug from Red Hat
Linux beta to Red Hat Public Beta.

I get this message from bugzilla:

"You are not permitted to edit bugs in product Red Hat Linux Beta."

when I try to edit that one.

Comment 3 Daniel Resare 2003-01-21 00:03:20 UTC
fyi redhat-artwork 0.60 doesn't solve the problem for me

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.