Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82281 - ARC=true is written in /etc/sysconfig/clock -> problems
Summary: ARC=true is written in /etc/sysconfig/clock -> problems
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: util-linux
Version: beta3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Ben Levenson
URL:
Whiteboard:
: 83383 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-20 20:12 UTC by giulioo
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-06 15:54:24 UTC


Attachments (Terms of Use)

Description giulioo 2003-01-20 20:12:03 UTC
Description of problem:
I'm 99% sure this is due to redhat-config-date, but not 100%.

My original "clock" had ARC "no" or "false", not "true". Now it's
$ cat /etc/sysconfig/clock
ZONE="Europe/Rome"
UTC=true
ARC=true
$
This causes problems in hwclock invocation at startup and shutdown because --arc
is used which is not supported by hwclock.

+ '[' -f /etc/sysconfig/clock ']'
+ . /etc/sysconfig/clock
++ ZONE=Europe/Rome
++ UTC=true
++ ARC=true
+ '[' '' = GMT ']'
+ '[' '' = ARC ']'
+ CLOCKDEF=
+ CLOCKFLAGS= --hctosys
+ CLOCKFLAGS= --hctosys --utc
+ CLOCKDEF= (utc)
+ CLOCKFLAGS= --hctosys --utc --arc
+ CLOCKDEF= (utc) (arc)
+ /sbin/hwclock --hctosys --utc --arc
/sbin/hwclock: unrecognized option `--arc'
hwclock - query and set the hardware clock (RTC)

Version-Release number of selected component (if applicable):
redhat-config-date-1.5.7-3
checked changelog for beta4 and didn't see anything related to this bug, so I
assume it's still there.

How reproducible:
Run redhat-config-date, don't know exactly the necessary steps. 
I discovered this sometime after I used the app and linked problem to it looking
at "clock" file mod date and rpm install date.

Comment 1 Brent Fox 2003-01-21 06:14:34 UTC
According to 'man hwclock', '--arc' is a valid option.  Also, according to Bill
Nottingham in bug #72149, ARC is a true/false field, so I believe that the
/etc/sysconfig/clock file that redhat-config-date has written is correct.  

Changing the component to util-linux, which is the package that hwclock is from.

Comment 2 Elliot Lee 2003-01-29 14:15:37 UTC
I would guess the real problem is that redhat-config-date interpreted the original "ARC=no" 
line as meaning "ARC=true", and rewrote the clock file that way...?

Since /etc/rc.d/rc.sysinit really expects ARC usage to come by the CLOCKMODE=ARC 
setting rather than ARC=true,
redhat-config-date should probably make sure that it only pays attention to 
$CLOCKMODE.

hwclock probably only has (and can have) a --arch option when built on the Alpha. This is 
one of those "not supposed to happen" situations that did.

Comment 3 Brent Fox 2003-02-03 18:49:05 UTC
Should be fixed with redhat-config-date-1.5.9.

Comment 4 Brent Fox 2003-02-04 20:52:02 UTC
*** Bug 83383 has been marked as a duplicate of this bug. ***

Comment 5 Jay Turner 2003-02-06 15:54:24 UTC
Fix confirmed with redhat-config-date-1.5.9-4.


Note You need to log in before you can comment on or make changes to this bug.