Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 822801 - RFE: Build Python3 bindings of libvirt API
Summary: RFE: Build Python3 bindings of libvirt API
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 822212 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-18 08:24 UTC by Daniel Berrange
Modified: 2012-11-27 15:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-09 17:50:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Daniel Berrange 2012-05-18 08:24:44 UTC
Description of problem:
The libvirt-python package currently provides Python2 bindings for libvirt. There needs to be a set of Python3 bindings for libvirt also distributed, in a libvirt-python3 sub-RPM.

Useful tutorial is here

http://python3porting.com/toc.html

Version-Release number of selected component (if applicable):
libvirt-0.9.12-1.el6

Comment 1 Peter Krempa 2012-05-18 09:21:54 UTC
*** Bug 822212 has been marked as a duplicate of this bug. ***

Comment 2 Dave Allan 2012-05-18 14:55:29 UTC
(In reply to comment #1)
> *** Bug 822212 has been marked as a duplicate of this bug. ***

You beat me to it.  :)


Note You need to log in before you can comment on or make changes to this bug.