Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82273 - screen corruptions with radio application
Summary: screen corruptions with radio application
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xawtv
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-20 18:53 UTC by David Balažic
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-11 18:11:16 UTC


Attachments (Terms of Use)
screenshot of radio running in screen on VT1 (deleted)
2003-01-20 18:57 UTC, David Balažic
no flags Details
screenshot of corrupted freq display (deleted)
2003-01-20 18:59 UTC, David Balažic
no flags Details

Description David Balažic 2003-01-20 18:53:05 UTC
Description of problem:

on VT2 ( /dev/tty2 )
when I press ctrl-L when "radio" is running, the screen gets corrupted,
the entire content of the "Tuner" subwindow moves one character to the left.
When pressing CRSR-UP or CRSR-DOWN after that , the frequency display is 
corrupted.
here is a "screenshot" after CTRL-L and CRSR-UP :
( the freq was 106.80, then it shuld be 106.85 )

              _   _     _   _       Up/Down     - inc/dec frequency
  STEREO  |  | | |_    |_| | _      PgUp/PgDown - next/prev station
  ****    |  |_| |_| . |_| | _|     g           - go to frequency...
                                    x           - exit
                                    ESC, q, e   - mute and exit

--

Problem 2 :

weird picture inside screen ( screen-3.9.13-2 ) :
see attachment

Version-Release number of selected component (if applicable):
xawtv-3.81-2


How reproducible:


Steps to Reproduce problem one :
1. start radio on textual terminal ( /dev/tty(1-6) )
2. press ctrl-L
3. press cursor-up or cursor-down
    
Actual results:

corrupted display of the tuned frequency

Expected results:

no corruption

Steps to Reproduce problem two :
1. start screen
2. inside screen start radio
    
Actual results:

corrupted display ( the borders ) , see attached textual screenshot

Expected results:

no corruption

Comment 1 David Balažic 2003-01-20 18:57:14 UTC
Created attachment 89443 [details]
screenshot of radio running in screen on VT1

Comment 2 David Balažic 2003-01-20 18:59:13 UTC
Created attachment 89444 [details]
screenshot of corrupted freq display

I put this also here, because the one in the comment is garbled.

Comment 3 Ngo Than 2003-04-01 10:59:41 UTC
Could you please try radia application in xterm. Does this issue show up here?
it

Comment 4 David Balažic 2003-04-02 07:55:06 UTC
The problem is not present anymore in Red Hat Linux 9 (Shrike).

I tried VT1,screen,xterm and gnome-terminal. radio looks OK in all of them.


Note You need to log in before you can comment on or make changes to this bug.