Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 822686 - Segfault when pressing escape with playing full-screen video in WMP
Summary: Segfault when pressing escape with playing full-screen video in WMP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Yonit Halperin
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-17 19:02 UTC by Marian Krcmarik
Modified: 2012-06-20 12:17 UTC (History)
7 users (show)

Fixed In Version: spice-server-0.10.1-10.el6
Doc Type: Bug Fix
Doc Text:
No Documentation Needed
Clone Of:
Environment:
Last Closed: 2012-06-20 12:17:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0765 normal SHIPPED_LIVE spice-server bug fix and enhancement update 2012-06-19 19:30:21 UTC

Description Marian Krcmarik 2012-05-17 19:02:35 UTC
Description of problem:
Segfault when pressing escape button with playing full-screen video in WMP.

Version-Release number of selected component (if applicable):
spice-server-0.10.1-9

How reproducible:
Always

Steps to Reproduce:
1. Connect to a Windows guest with remote-viewer.
2. Play video in Windows Media Player in full-screen mode
3. Press Escape button on keyboard
  
Actual results:
Qemu process segfaults

Expected results:
Escape full-screen mode and video plays smoothly

Additional info:

Comment 1 Marian Krcmarik 2012-05-17 19:14:13 UTC
Bisected by Yonit (yhalperi) and patch available on mailing list:
http://lists.freedesktop.org/archives/spice-devel/2012-May/009215.html

So I am moving to POST.

Comment 3 Yonit Halperin 2012-05-21 14:47:05 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation Needed

Comment 7 errata-xmlrpc 2012-06-20 12:17:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0765.html


Note You need to log in before you can comment on or make changes to this bug.