Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82266 - diskdruid freezes when clicking on partition (drive has 40 partitions)
Summary: diskdruid freezes when clicking on partition (drive has 40 partitions)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-20 17:50 UTC by David Balažic
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-15 20:16:27 UTC


Attachments (Terms of Use)
Partition table dump (deleted)
2003-01-22 09:02 UTC, David Balažic
no flags Details

Description David Balažic 2003-01-20 17:50:25 UTC
Description of problem:

GUI install from CD, fresh install, custom, manual partitioning :
If I click on the hdd1 partition in the upper block/gfx representation of 
partitions, the entire GUI freezes, except the mouse. I fswitch to VT1 and 
back, nothing is redrawn. There is only light gray background and two big white 
rectangles where the online help was and one where the diskdruid text table of 
partitions was.

Version-Release number of selected component (if applicable):

redhat linux/x86 8.0.92 phoebe
anaconda-8.0.92-8

How reproducible:

always. It happens every time I try.

Steps to Reproduce:
1. start GUI install
2. get into disk druid
3. click on hdd1
    
Actual results:

freeze

Expected results:

normal work

Additional info:

I have two hard drives :
hdc : hdc1 hdc2 hdc5 hdc6 <free space>
hdd : hdd1 ... hdd40 ( fourty )

I created the 40 partitions with the same diskdruid on a prevoius installation. 
Only one disk was mounted at that time.

Comment 1 Michael Fulbright 2003-01-21 17:37:04 UTC
I'll have to see if I can reproduce this.

Comment 2 David Balažic 2003-01-22 09:02:55 UTC
Created attachment 89509 [details]
Partition table dump

Here are my partition tables, printed with "sfdisk -d"

Comment 3 Michael Fulbright 2003-02-12 17:22:15 UTC
Thanks for the additional information.

Comment 4 Jeremy Katz 2003-10-15 20:16:27 UTC
This works for me with current trees and 42 partitions.


Note You need to log in before you can comment on or make changes to this bug.