Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82261 - man terminates when suspended
Summary: man terminates when suspended
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
: 73002 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-20 17:29 UTC by David Balažic
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-07 21:47:33 UTC


Attachments (Terms of Use)

Description David Balažic 2003-01-20 17:29:09 UTC
Description of problem:

If I press ctrl-Z when man is displaying a manual page, then man can not be 
restored any more.

Version-Release number of selected component (if applicable):

man-1.5j-12.i386.rpm

How reproducible:


Steps to Reproduce:
1. login on VT1
2. "man sfdisk"
3. ctrl-Z
4. "fg"
    
Actual results:

man exits

Expected results:

man resumes and can be used to view the page

Additional info:

ctrl-Z works fine with other programs, like sleep , less or vi

Comment 1 David Balažic 2003-01-30 18:16:32 UTC
Same thing in phoebe2 ( 8.0.93 ).
man-1.5k-2

All default settings; shell is bash etc.

Comment 2 Bill Nottingham 2003-02-11 05:40:06 UTC
Works for me with current packages - does it work for you?

Comment 3 David Balažic 2003-02-13 09:29:42 UTC
Yes, but there is still something weird :

man ls
press ctrl-Z after the page appear :
no shell prompt.
press RETURN -> shell prompt appears.

This happens if ctrl-z is pressed in less than 9 seconds
after man ls is started. If pressed after 9 or more seconds,
then it behaves OK.


Comment 4 David Balažic 2003-02-14 08:40:00 UTC
More info :
kernel-2.4.20-2.21 -> man on ctrl-z exits ( terminates )
kernel-2.4.20-2.41 -> man on ctrl-z stops, with the 9 second issue descibed in 
comment #3



Comment 5 Eido Inoue 2003-08-07 21:47:33 UTC
I'm going to leave this as a feature for upstream. Most apps that do non-trivial
screen manipulation with a library have to be specifically written to support
application suspension. (that is, put the terminal in a sane state) Hence the
need for a "terminal reset" feature in most X-based terminal programs...

Comment 6 Eido Inoue 2003-08-07 21:48:44 UTC
*** Bug 73002 has been marked as a duplicate of this bug. ***

Comment 7 David Balažic 2003-08-08 14:32:25 UTC
> most X-based terminal programs

? I was doing everything on text console, without X

Comment 8 Eido Inoue 2003-08-08 15:27:25 UTC
The analogy for a terminal reset in the console would be something like "stty sane"


Note You need to log in before you can comment on or make changes to this bug.