Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8226 - fdisk doc bug (-l no longer defaults to a set of devices)
Summary: fdisk doc bug (-l no longer defaults to a set of devices)
Keywords:
Status: CLOSED DUPLICATE of bug 9755
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 6.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-06 06:54 UTC by James Manning
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-03-05 15:44:44 UTC


Attachments (Terms of Use)

Description James Manning 2000-01-06 06:54:12 UTC
fdisk used to allow fdisk -l with no params and would sweep through
an ever-growing list of devices.  Changed (fixed? :)  by aeb in July,99
as per fdisk/fdisk.c line 76 and realized on line 1906.
Not a bad decision, but /usr/man/man8/fdisk.8 should catch up.

--- fdisk/fdisk.8.old Thu Jan  6 01:50:19 2000
+++ fdisk/fdisk.8     Thu Jan  6 01:50:50 2000
@@ -175,11 +175,7 @@
 program and exit.
 .TP
 .B \-l
-List the partition tables for
-.BR /dev/hd[a-d] ,
-.BR /dev/sd[a-h] ,
-.BR /dev/ed[a-d] ,
-and then exit.
+List the partition tables for the specified devices.
 .TP
 .B \-u
 When listing partition tables, give sizes in sectors instead

Comment 1 Dale Lovelace 2000-03-05 15:44:59 UTC
*** This bug has been marked as a duplicate of 9755 ***


Note You need to log in before you can comment on or make changes to this bug.