Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 822418 - RFE: print channel name in addition to code in 'info spice'
Summary: RFE: print channel name in addition to code in 'info spice'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 6.4
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1201000
TreeView+ depends on / blocked
 
Reported: 2012-05-17 10:00 UTC by David Jaša
Modified: 2015-07-22 06:02 UTC (History)
18 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.458.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1201000 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:02:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1275 normal SHIPPED_LIVE qemu-kvm bug fix and enhancement update 2015-07-20 17:49:16 UTC

Description David Jaša 2012-05-17 10:00:37 UTC
Description of problem:
add channel name to 'info spice' output. Current implementation shows just channel codes like 1:0, printing of channel name there would make some debugging & verifcations easier.

Version-Release number of selected component (if applicable):
spice-server-0.10.1-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run: qemu-kvm -monitor stdio -spice port=5900
2. connect to the qemu with client
3. type into qemu monitor: info spice
  
Actual results:
output like this is printed:
Server:
     address: 0.0.0.0:5800
        auth: none
Channel:
     address: 127.0.0.1:33058
     session: 1804289383
     channel: 1:0
(...)

Expected results:
Server:
     address: 0.0.0.0:5800
     address: 0.0.0.0:5801 [tls]
        auth: none
Channel:
     address: 127.0.0.1:33058
     session: 1804289383
     channel: 1:0
     name: main

Additional info:

Comment 1 David Jaša 2012-06-26 14:03:23 UTC
Looking into the code, it looks more like qemu RFE than spice-server one. Qemu monitor output is defined in qemu's hmp.c while spice channel codes are defined in spice-protocol and spice-server respectively:

http://cgit.freedesktop.org/spice/spice-protocol/tree/spice/enums.h#n337
http://cgit.freedesktop.org/spice/spice/tree/server/reds.c#n3959

Comment 2 RHEL Product and Program Management 2012-07-10 05:47:32 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2012-07-11 02:01:57 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 4 David Blechter 2012-10-15 17:52:00 UTC
Too late for 6.4, moving to 6.5, not a blocker

Comment 6 RHEL Product and Program Management 2013-10-14 05:00:03 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 7 Marc-Andre Lureau 2014-06-18 17:54:39 UTC
this is more a qemu rfe actually.

The HMP prints chan->value->channel_type, the channel type is defined by the protocol. Arguably, spice server could provide a spice_channel_type_to_string() but I don't think that's really necessary here. 

moving to 6.7

Comment 8 Cole Robinson 2015-02-26 19:36:11 UTC
Patch posted upstream:

https://lists.gnu.org/archive/html/qemu-devel/2015-02/msg05163.html

Comment 9 Cole Robinson 2015-03-02 17:13:25 UTC
v3 here was applied to gerd's queue:

https://lists.gnu.org/archive/html/qemu-devel/2015-03/msg00009.html

Comment 10 Ademar Reis 2015-03-03 21:00:54 UTC
(In reply to Cole Robinson from comment #9)
> v3 here was applied to gerd's queue:
> 
> https://lists.gnu.org/archive/html/qemu-devel/2015-03/msg00009.html

Will you post a backport to RHEL6.7?

Comment 11 Cole Robinson 2015-03-04 15:54:12 UTC
Posted for RHEL6.7 now:

http://post-office.corp.redhat.com/archives/rhvirt-patches/2015-March/msg00093.html

Comment 13 Jeff Nelson 2015-03-16 04:48:57 UTC
Fix included in qemu-kvm-0.12.1.2-2.458.el6

Comment 15 Chao Yang 2015-03-17 10:32:31 UTC
Reproduced with qemu-kvm-0.12.1.2-2.457.el6.x86_64.

Steps:

1. boot a guest with:
...
-vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=33554432 -spice port=5900,tls-port=5901,x509-dir=/root/openss/,addr=xx,tls-channel=main,tls-channel=display,tls-channel=inputs,tls-channel=cursor,tls-channel=playback,tls-channel=record,tls-channel=smartcard,tls-channel=usbredir,disable-ticketing 

2. set up connection through remote-viewer like

remote-viewer --spice-ca-file=ca-cert.pem --spice-secure-channels=all --spice-host-subject="C=IL, L=Raanana, O=Red Hat, CN=my server" spice://xx:5900?tls-port=5901 

3. check output of info spice through hmp

(qemu) info spice 
Server:
     migrated: false
     address: xx:5900
     address: xx:5901 [tls]
        auth: none
Channel:
     address: xx:52351 [tls]
     session: 1555366655
     channel: 1:0
Channel:
     address: xx:52352 [tls]
     session: 1555366655
     channel: 5:0
Channel:
     address: xx:52353 [tls]
     session: 1555366655
     channel: 6:0
Channel:
     address: xx:52354 [tls]
     session: 1555366655
     channel: 2:0
Channel:
     address: xx:52355 [tls]
     session: 1555366655
     channel: 3:0
Channel:
     address: xx:52356 [tls]
     session: 1555366655
     channel: 4:0




Verified pass with qemu-kvm-0.12.1.2-2.458.el6.x86_64. After step 3:

(qemu) info spice 
Server:
     migrated: false
     address: xx:5900
     address: xx:5901 [tls]
        auth: none
Channel:
     address: xx:52345 [tls]
     session: 162496269
     channel: 1:0
     channel name: main
Channel:
     address: xx:52346 [tls]
     session: 162496269
     channel: 5:0
     channel name: playback
Channel:
     address: xx:52347 [tls]
     session: 162496269
     channel: 6:0
     channel name: record
Channel:
     address: xx:52348 [tls]
     session: 162496269
     channel: 2:0
     channel name: display
Channel:
     address: xx:52349 [tls]
     session: 162496269
     channel: 3:0
     channel name: inputs
Channel:
     address: xx:52350 [tls]
     session: 162496269
     channel: 4:0
     channel name: cursor


I don't have smartcard and usbredir setup, so didn't test them. But I think it is adequate to verify this bug. 

Moving to VERIFIED.

Comment 17 errata-xmlrpc 2015-07-22 06:02:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1275.html


Note You need to log in before you can comment on or make changes to this bug.