Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82241 - Can't activate ISDN connection with 'neat'.
Summary: Can't activate ISDN connection with 'neat'.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks: 79579 81720 85893 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-20 11:52 UTC by Inger Karin Haarbye
Modified: 2015-01-08 00:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:08:14 UTC


Attachments (Terms of Use)
Traceback when trying to activate ISDN-card with neat. (deleted)
2003-06-02 17:48 UTC, Inger Karin Haarbye
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Inger Karin Haarbye 2003-01-20 11:52:44 UTC
Description of problem: 
 
I use neat to configure ISDN-connection to my ISP. This seems to work, but 
when I try to activate the connection it fails. 
 
Version-Release number of selected component (if applicable): 
redhat-config-network-1.1.90-1 
 
How reproducible: 
All the time 
 
Steps to Reproduce: 
1. Configure isdn-card and connection with 'neat'. 
2. Try to activate the connection 
3. 
     
Actual results: 
Error message about 'cannot activate device isdn0' (first time), if I try 
again I get no error message from 'neat', but 'Jan 20 12:45:24 opuntia kernel: 
isdn_ppp_bind: Can't find a (free) connection to the ipppd daemon' in 
/var/log/messages. In both cases no connection to ISP. 
 
Expected results: 
 
 
Additional info: At boot setting up isdn0 fails.

Comment 1 Harald Hoyer 2003-02-05 12:57:05 UTC
reassigning

Comment 2 Ngo Than 2003-02-05 16:28:26 UTC
which isdn card do you have? Is it supported from neat?
Could you please send to me following files:

- /etc/sysconfig/isdncard
- /etc/sysconfig/network-scripts/ifcfg-ipppX


Thanks


Comment 3 Inger Karin Haarbye 2003-02-16 23:38:59 UTC
It has been supported in earlier versions. It is possible to get it work "the 
old way", with scripts and so on. I usually don't use isdn, I have ADSL. I 
still have my old ISDN-card: Teles 16.3C PnP with HFC-chip. 
Everything in /var/log/messages looks OK until dial. 
 
/etc/sysconfig/isdncard: 
 
NAME="Teles 16.3c PnP" 
MODULE="hisax" 
VENDOR_ID="TAG2610" 
DEVICE_ID="TAG2610" 
RESOURCES="protocol=2 type=14 irq=3 id=HiSax io=0x580" 
 
/etc/sysconfig/network-scripts/ifcfg-isdn0 (Yes, that is the device you use 
now! Not ippp0.): 
 
# Please read /usr/share/doc/initscripts-*/sysconfig.txt 
# for the documentation of these parameters. 
USERCTL=yes 
PEERDNS=yes 
TYPE=ISDN 
DEVICE=isdn0 
BOOTPROTO=dialup 
ONBOOT=no 
NAME=OnlineTrafikk 
DEFROUTE=yes 
PERSIST=off 
SECURE=off 
BUNDLING=off 
HUPTIMEOUT=600 
DIALMODE=manual 
ENCAP=syncppp 
USER=haarbye 
PHONE_OUT=81007007 
PREFIX=1533 
MSN=62530679 
AUTH='+pap -chap' 
PROVIDER=OnlineTrafikk 
CALLBACK=off 
CCP=off 
PC=off 
AC=off 
BSDCOMP=off 
VJ=off 
VJCCOMP=off 
 

Comment 4 Ngo Than 2003-02-17 23:49:08 UTC
Harald: redhat-config-network added wrong isdn device in config file.
The device should be ippp by ENCAP=syncppp. and isdn by ENCAP=rawip

it's a bug in redhat-config-network. moving it to redhat-config-network

Comment 5 Inger Karin Haarbye 2003-02-26 08:23:13 UTC
The problem is still here in beta5: No possibility to use ISDN with neat. 

Comment 8 Inger Karin Haarbye 2003-04-11 11:51:59 UTC
The problem is still here in Shrike (Red Hat 9): No possibility to use ISDN 
with neat. 

Comment 9 Inger Karin Haarbye 2003-05-18 23:25:40 UTC
Same problem with Cambridge (Red Hat 9.0.90) Alpha1. neat uses device isdn0 
and not ippp0. This just doesn't work. 
Neat/ISDN has been working fine with earlier versions of Red Hat.  

Comment 10 Inger Karin Haarbye 2003-06-02 17:46:16 UTC
It looks like ippp0 is used now, but when I try to activate the interface, I 
get a traceback. Maybe this should be filed as a separate bug, but I really 
don't know what causes what here... 

Comment 11 Inger Karin Haarbye 2003-06-02 17:48:22 UTC
Created attachment 92095 [details]
Traceback when trying to activate ISDN-card with neat.

Red Hat beta (alfa2) Cambridge 9.0.91.

Comment 12 Inger Karin Haarbye 2003-07-24 09:28:00 UTC
The problem with wrong device seems to be corrected in Severn.

I still can't get "neat" to work properly with isdn (it is not dialing), but I
suppose this is a different problem, bug #100677 

Comment 13 Harald Hoyer 2003-08-11 14:08:14 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.