Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82229 - non existent label mounts even with the 'noauto' option cause boot time drop to emergency shell
Summary: non existent label mounts even with the 'noauto' option cause boot time drop ...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-20 04:50 UTC by Matthew Galgoci
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 20:34:56 UTC


Attachments (Terms of Use)

Description Matthew Galgoci 2003-01-20 04:50:47 UTC
Description of problem:

I have a removable disk drive that I want to mount using a filesystem label.

The drive contains an ext3 filesystem labeled as /mnt/shemp

/mnt/shemp exists

I also have the following entry in /etc/fstab:

LABEL=/mnt/shemp   /mnt/shemp              ext3    noauto        1 1

Upon rebooting without /mnt/shep available in the system, I am dropped to 
a filesystem repair shell (of course first prompting for the root password).

Version-Release number of selected component (if applicable):

initscripts-7.04-1

How reproducible:

Every time.

Steps to Reproduce:
1. Add a non-existent label mount to /etc/fstab with the noauto option
2. reboot
3. watch it prompt you for your root password and to fix your filesystem
    
Actual results:

You are prompted to fix the filesystem

Expected results:

The non-existent label with the noauto option should simply be ignored since 
you are not going to mount the filesystem automagically anyhow.

Comment 1 Bill Nottingham 2003-01-20 20:40:15 UTC
Did this happen previously?

Comment 2 Matthew Galgoci 2003-01-20 21:07:03 UTC
I could have sworn it worked before, but I just tried on an advanced server
2.1 with all current updates and it indeed failed.

However, on a hunch I changed the fs_freq and fs_passno fields both to 0 and 
the system booted without complaint. Weird.

Is it semantically correct behaviour? 

I will test the beta4 box again tonight when I get home to ensure that the same
behaviour holds.

Comment 3 Bill Nottingham 2005-09-29 20:34:56 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.