Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82215 - An error has occured in the Date and Time module
Summary: An error has occured in the Date and Time module
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-20 02:08 UTC by greg hosler
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:15 UTC


Attachments (Terms of Use)

Description greg hosler 2003-01-20 02:08:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Just installed Phoebe II.

nis client (with incorrect NIS domain name, by accident, but might be related).

when firstboot ran, immediately I get an error box complaining

"An error has occured in the Date and Time module"

The first callback is:

  /usr/share/firstbootWindow.py line 153

TypeError: gethostbyaddr() arguement must be String not None

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. install new system. 
2. boot first time
3.
    

Actual Results:  No date/time setup in first boot

Expected Results:  no error box.

Additional info:

p[ossibly relavant, possibly not. the nis domainname was wrong.

Comment 1 Brent Fox 2003-01-20 16:06:08 UTC
Do you mean NIS or NTP?  

Also, did firstboot crash immediately or did you enter a server into the NTP
entry and then click Forward?

Comment 2 greg hosler 2003-01-20 23:24:20 UTC
actually, i DID mean "NIS" (not NTP)

firstboot (as a whole) didn't seem to crash. but the date/time thingie of
firstboot did crash. I never saw the date/time screen (I am assuming that that
is where you enter the "NTP entry", yes ?

Comment 3 Brent Fox 2003-01-23 17:38:37 UTC
Ah, ok.  I don't think that NIS has anything to do with this problem then.  Did
the traceback you saw look anything like:

  File "/usr/share/redhat-config-date/redhat-config-date.py", line 48, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 180, in __init__
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

It probably appeared in a window just as firstboot was starting up, right?  If
so, then this is a duplicate of bug #82061.

Comment 4 greg hosler 2003-01-24 10:56:01 UTC
yes, looks like a dup of 82061. by the way, I _did_ do a bugzilla search (on
firstboot as I recall) before entering the bug, and nothing showed up.

:(


Comment 5 Brent Fox 2003-01-24 19:35:52 UTC
That may be because the date/time screen in firstboot is actually the code from
redhat-config-date, so most of the bugs may have been filed against that
component.  This would explain why your Bugzilla query turned up nothing. 
Resolving as a duplicate.  Thanks for your report.

*** This bug has been marked as a duplicate of 82061 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:51:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.