Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 822 - NFS server crashes when written to by client using NFS over TCP
Summary: NFS server crashes when written to by client using NFS over TCP
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-13 19:09 UTC by keithu@parl.clemson.edu
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-18 21:59:47 UTC


Attachments (Terms of Use)

Description keithu@parl.clemson.edu 1999-01-13 19:09:32 UTC
We are running RedHat 5.2 with nfs-server-2.2beta37.  We
have installed a new kernel (2.1.131-ac9 patched to run md).
When mounting file systems from this server using NFS over
TCP, and then writing to the server, it usually causes the
server to crash.  Sometimes, however, it just disallows the
write (permission denied) or reports that the file you are
trying to write to is a directory.

I have emailed Olaf Kirch who suggested the problem is
probably in glibc:

-----------------------------------------------------------
I have no idea where the UDP problem may come from. The TCP
problem however is most likely caused by the glibc-2.0.7 RPC
code. If you want to recompile glibc, look at
sunrpc/svc_tcp.c and diff it against an earlier
version of glibc.  You'll notice that a call to
svc_getreqset or some such was added to the readtcp()
function; replace all of readtcp() with the older version
and you should be fine.

Or ask RedHat whether they have made a fixed version.

Olaf
---------------------------------------------------------

We have a patch and are currently building an RPM to solve
our immediate problems.

				Keith Underwood
				Clemson University

Comment 1 Aleksey Nogin 1999-01-14 05:22:59 UTC
Take a look at the list of 2.2.0pre problems at
http://roadrunner.swansea.linux.org.uk/jobs.shtml

In particualar it lists (as a problem not fixed by ac patches):
 - NFS client over tcp doesnt work. Now fixed read side

Comment 2 keithu@parl.clemson.edu 1999-01-14 19:50:59 UTC
Sorry, I should have been more specific.  The NFS clients using TCP
are Solaris 2.5.1 and Dec Unix 4.0c machines.  The NFS server can
serve NFS over TCP.  We have created a temporary patch to glibc based
on Olaf Kirch's recommendation which alleviated the problem, though I
would still like an official update from RedHat.

Comment 3 David Lawrence 1999-03-11 17:01:59 UTC
This has been assigned to a glibc developer for further review.

Comment 4 Cristian Gafton 1999-03-18 21:59:59 UTC
This should be fixed in the current beta or in the newer 2.2 kernels


Note You need to log in before you can comment on or make changes to this bug.