Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82189 - bad source code
Summary: bad source code
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact:
URL:
Whiteboard:
: 105840 110767 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-19 10:30 UTC by d.binderman
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-10 19:12:39 UTC


Attachments (Terms of Use)

Description d.binderman 2003-01-19 10:30:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package mysql-3.23.52-3 from Redhat 8.0

The compiler said

ut0ut.c:59: warning: right shift count >= width of type
dict0load.c:340: warning: too many arguments for format
log0recv.c:1384: warning: too few arguments for format
log0recv.c:1401: warning: too few arguments for format
log0recv.c:1429: warning: too few arguments for format

Here is an untested patch to shut up the compiler.

*** ./innobase/log/log0recv.c.old	2003-01-16 21:46:23.000000000 +0000
--- ./innobase/log/log0recv.c	2003-01-16 21:48:18.000000000 +0000
***************
*** 1381,1387 ****
  							&success);
  			if (!success) {
  				printf(
! "InnoDB: Error: cannot open %lu'th data file %s\n", nth_file);
  
  				exit(1);
  			}
--- 1381,1387 ----
  							&success);
  			if (!success) {
  				printf(
! "InnoDB: Error: cannot open %lu'th data file %s\n", nth_file, data_files[nth_file]);
  
  				exit(1);
  			}
***************
*** 1398,1404 ****
  			if (!success) {
  				printf(
  "InnoDB: Error: cannot read page no %lu from %lu'th data file %s\n",
! 				nth_page_in_file, nth_file);
  
  				exit(1);
  			}
--- 1398,1404 ----
  			if (!success) {
  				printf(
  "InnoDB: Error: cannot read page no %lu from %lu'th data file %s\n",
! 				nth_page_in_file, nth_file, data_files[nth_file]);
  
  				exit(1);
  			}
***************
*** 1426,1432 ****
  			if (!success) {
  				printf(
  "InnoDB: Error: cannot write page no %lu to %lu'th data file %s\n",
! 				nth_page_in_file, nth_file);
  
  				exit(1);
  			}
--- 1426,1432 ----
  			if (!success) {
  				printf(
  "InnoDB: Error: cannot write page no %lu to %lu'th data file %s\n",
! 				nth_page_in_file, nth_file, data_files[nth_file]);
  
  				exit(1);
  			}

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile the program
2.
3.
    

Additional info

Comment 1 Patrick Macdonald 2003-02-19 15:19:47 UTC
Yes, these problems still exist in the current production (3.23.55) release.
We'll notify upstream.

Comment 2 Patrick Macdonald 2003-06-10 19:12:39 UTC
This has been fixed, according to the bug report, in MySQL 4.0.

Please see MySQL bug 287.

http://bugs.mysql.com/bug.php?id=287

Comment 3 Patrick Macdonald 2003-09-29 13:54:45 UTC
*** Bug 105840 has been marked as a duplicate of this bug. ***

Comment 4 Patrick Macdonald 2003-11-24 15:26:38 UTC
*** Bug 110767 has been marked as a duplicate of this bug. ***

Comment 5 David Binderman 2004-11-23 11:07:00 UTC
>This has been fixed, according to the bug report, in MySQL 4.0.

But when does MySQL 4.0 get into Fedora ?

In Fedora Core 3, the three problems in file log0recv.c still exist.

This bug report is nearly two years old and still isn't completely fixed.

Comment 6 Patrick Macdonald 2004-11-23 15:22:39 UTC
It has been fixed but Fedora Core still ships MySQL 3.23 due to
legal issues.  


Note You need to log in before you can comment on or make changes to this bug.