Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82186 - broken source code
Summary: broken source code
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: krb5
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
: 105838 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-19 10:14 UTC by d.binderman
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-18 19:58:38 UTC


Attachments (Terms of Use)

Description d.binderman 2003-01-19 10:14:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)

Description of problem:

Hello there,

I just tried to compile package krb5-1.2.5-6 from Redhat 8.0

The compiler said

client.c:220: warning: too few arguments for format
client.c:326: warning: too few arguments for format
./ftpcmd.y:1287: warning: operation on `state' may be undefined

Here is an untested patch to shut up the compiler

*** ./src/appl/gssftp/ftpd/ftpcmd.y.old	2003-01-12 11:02:39.000000000 +0000
--- ./src/appl/gssftp/ftpd/ftpcmd.y	2003-01-12 11:05:40.000000000 +0000
***************
*** 1284,1290 ****
  		dostr1:
  			if (cbuf[cpos] == ' ') {
  				cpos++;
! 				state = state == OSTR ? STR2 : ++state;
  				return (SP);
  			}
  			break;
--- 1284,1290 ----
  		dostr1:
  			if (cbuf[cpos] == ' ') {
  				cpos++;
! 				state = (state == OSTR) ? STR2 : (state + 1);
  				return (SP);
  			}
  			break;
*** ./src/lib/rpc/unit-test/client.c.old	2003-01-12 10:58:40.000000000 +0000
--- ./src/lib/rpc/unit-test/client.c	2003-01-12 11:05:13.000000000 +0000
***************
*** 217,223 ****
  	  if (strncmp(*echo_resp, "Echo: ", 6) &&
  	      strcmp(echo_arg, (*echo_resp) + 6) != 0)
  	       fprintf(stderr, "RPC_TEST_ECHO call %d response wrong: "
! 		       "arg = %s, resp = %s\n", echo_arg, *echo_resp);
  	  gssrpc_xdr_free(xdr_wrapstring, echo_resp);
       }
  
--- 217,223 ----
  	  if (strncmp(*echo_resp, "Echo: ", 6) &&
  	      strcmp(echo_arg, (*echo_resp) + 6) != 0)
  	       fprintf(stderr, "RPC_TEST_ECHO call %d response wrong: "
! 		       "arg = %s, resp = %s\n", i, echo_arg, *echo_resp);
  	  gssrpc_xdr_free(xdr_wrapstring, echo_resp);
       }
  
***************
*** 323,329 ****
  	       if (strncmp(*echo_resp, "Echo: ", 6) &&
  		   strcmp(echo_arg, (*echo_resp) + 6) != 0)
  		    fprintf(stderr,
! 			    "RPC_TEST_LENGTHS call %d response wrong\n");
  	       gssrpc_xdr_free(xdr_wrapstring, echo_resp);
  	  }
  	  
--- 323,329 ----
  	       if (strncmp(*echo_resp, "Echo: ", 6) &&
  		   strcmp(echo_arg, (*echo_resp) + 6) != 0)
  		    fprintf(stderr,
! 			    "RPC_TEST_LENGTHS call %d response wrong\n", i);
  	       gssrpc_xdr_free(xdr_wrapstring, echo_resp);
  	  }
  	  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile the program
2.
3.
    

Additional info

Comment 1 Marcin Garski 2004-12-18 19:58:38 UTC
Thank you for the bug report. However this bugs should be reported
upstream (and fixed by MIT krb5 developers) so everyone could use
fixed version (not just Fedora Core users).

This bugs are fixed in version 1.3.5 (also could be in earlier
releases but I haven't check that).

Comment 2 Marcin Garski 2004-12-18 20:01:35 UTC
*** Bug 105838 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.