Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 821557 - SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/systemd-kmsg-syslogd.
Summary: SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/...
Keywords:
Status: CLOSED DUPLICATE of bug 821810
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:75fc5666cfd09d8b28f73990277...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-14 22:33 UTC by naccarip
Modified: 2012-05-16 04:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-16 04:19:27 UTC


Attachments (Terms of Use)

Description naccarip 2012-05-14 22:33:48 UTC
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.5-2.fc16.x86_64
reason:         SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/systemd-kmsg-syslogd.
time:           mar 15 mag 2012 00:33:18 CEST

description:
:SELinux is preventing /usr/bin/ruby from 'getattr' accesses on the file /lib/systemd/systemd-kmsg-syslogd.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If si crede che ruby dovrebbe avere possibilità di accesso getattr sui systemd-kmsg-syslogd file in modo predefinito.
:Then si dovrebbe riportare il problema come bug.
:E' possibile generare un modulo di politica locale per consentire questo accesso.
:Do
:consentire questo accesso per il momento eseguendo:
:# grep deltacloudd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:deltacloudd_t:s0
:Target Context                system_u:object_r:syslogd_exec_t:s0
:Target Objects                /lib/systemd/systemd-kmsg-syslogd [ file ]
:Source                        deltacloudd
:Source Path                   /usr/bin/ruby
:Port                          <Sconosciuto>
:Host                          (removed)
:Source RPM Packages           ruby-1.8.7.358-1.fc16.x86_64
:Target RPM Packages           systemd-37-19.fc16.x86_64
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux mattia.fedoraonline 3.3.5-2.fc16.x86_64 #1
:                              SMP Tue May 8 11:24:50 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    mar 15 mag 2012 00:26:14 CEST
:Last Seen                     mar 15 mag 2012 00:26:14 CEST
:Local ID                      a4dd37ba-983b-4632-98f6-8f860f8ab911
:
:Raw Audit Messages
:type=AVC msg=audit(1337034374.95:103): avc:  denied  { getattr } for  pid=989 comm="deltacloudd" path="/lib/systemd/systemd-kmsg-syslogd" dev="sda3" ino=380358 scontext=system_u:system_r:deltacloudd_t:s0 tcontext=system_u:object_r:syslogd_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337034374.95:103): arch=x86_64 syscall=lstat success=yes exit=0 a0=18b2ce0 a1=7fff4bfa2610 a2=7fff4bfa2610 a3=1 items=0 ppid=911 pid=989 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=deltacloudd exe=/usr/bin/ruby subj=system_u:system_r:deltacloudd_t:s0 key=(null)
:
:Hash: deltacloudd,deltacloudd_t,syslogd_exec_t,file,getattr
:
:audit2allow
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t syslogd_exec_t:file getattr;
:
:audit2allow -R
:
:#============= deltacloudd_t ==============
:allow deltacloudd_t syslogd_exec_t:file getattr;
:

Comment 1 Daniel Walsh 2012-05-16 04:19:27 UTC

*** This bug has been marked as a duplicate of bug 821810 ***


Note You need to log in before you can comment on or make changes to this bug.