Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82149 - kernel-2.4.20-2.21 rpm scripts assume use of kernel with software raid compiled in
Summary: kernel-2.4.20-2.21 rpm scripts assume use of kernel with software raid compil...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-18 07:51 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-20 21:22:22 UTC


Attachments (Terms of Use)

Description Nathan G. Grennan 2003-01-18 07:51:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
I downloaded kernel-2.4.20-2.21 and installed it. During the install process I
got the error message below. I am running a custom recompile of
kenrel-2.4.20-2.12 without raid support.

awk: cmd. line:2: fatal: cannot open file `/proc/mdstat' for reading (No such
file or directory)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot kernel without raid support
2. Install kernel-2.4.20-2.21
3.
    

Actual Results:  awk: cmd. line:2: fatal: cannot open file `/proc/mdstat' for
reading (No such file or directory)


Expected Results:  no error message

Additional info:

RedHat seems to be getting pretty bad about assume use of their kernel, and even
their compile options. I think this is something that should be recongized and
stopped.

On a bright note RedHat does seem to be willing to fix such assumptions when
they come up.

Comment 1 Bill Nottingham 2003-01-20 21:22:22 UTC
Fixed in 3.4.36-1.


Note You need to log in before you can comment on or make changes to this bug.