Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82148 - firstboot fails after fresh install
Summary: firstboot fails after fresh install
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-18 06:44 UTC by Ulrich Drepper
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:14 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2003-01-18 06:44:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030117

Description of problem:
After a completely fresh install upon the first boot, firstboot fails.  A window
with firstboot.py in the tital pops up and reads:

Traceback (most recent call list):
 File "/usr/share/fistboot/firstbootWindow.py", line 153, in __init__
  vbox, eventbox = module.launch()
 File "/usr/share/firstboot/modules/data.py", line 75, in launch
  self.setupScreen()
 File "/usr/share/firstboot/modules/data.py", line 64, in setUpScreen
  self.dataPage = data_gui.datePage(self.dataBackend)
 File "/usr/share/redhat-config-data/data_gui.py", line 171, in __init__
  ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None


Since there is a problem with the Data and Time module,
Red Hat Setup Agent will not load this module and
will attempt to run the remaining modules.

Please file a bug [...]


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Fresh install.
2.Reboot
3.
    Is there something about ntp versions in the installer?  I don't
think I've selected anything.

Actual Results:  Above message in a window

Expected Results:  firstboot GUI

Additional info:

Comment 1 Brent Fox 2003-01-18 17:40:52 UTC
No, nothing wrong with ntp.  It was a bug on my part in redhat-config-date.

*** This bug has been marked as a duplicate of 82061 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.