Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82144 - CPAN installation of Template Toolkit 2.08 fails tests
Summary: CPAN installation of Template Toolkit 2.08 fails tests
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-18 04:15 UTC by Shankar Unni
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-28 07:24:38 UTC


Attachments (Terms of Use)

Description Shankar Unni 2003-01-18 04:15:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
If I use the CPAN module to install the Template Toolkit:

  perl -MCPAN -e 'install "Template"'

(Template toolkit downloaded is 2.08), I get a failure in an HTML test (#3 out
of 10 in t/html.t).

Using Perl 5.8.0 out of the box (from the RPM in the 8.0 media).

The precise test is:

-- test --
[% TRY;
      "Léon Brocard" | html_entity;
   CATCH;
     error;
   END
%]
-- expect --
-- process --
[%  IF entities -%]
Léon Brocard
[%- ELSE -%]
html_all error - cannot locate Apache::Util or HTML::Entities
[%- END %]

It seems this test is throwing an error.

It does work fine on Perl 5.6.1 on a RedHat 7.2 box.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above: execute

  perl -MCPAN -e 'install "Template"'


Actual Results:  A single failure running the "html" tests, and so CPAN refuses
to install the package.

Expected Results:  No failures, successful install.

Additional info:

Bugzilla depends on the Template toolkit, so this is (for us, anyway) severe..

Comment 1 Chip Turner 2003-01-18 13:33:17 UTC
this is a false breakage.  try the following:

export PERLIO=stdio
perl -MCPAN -e 'install "Template"'

That will probably be a sufficient workaround.  Or you can try the latest perl
in Rawhide.  The core issue is utf8 trouble, most of which is fixed in the
latest perl.

Comment 2 Shankar Unni 2003-01-23 18:41:31 UTC
Ah, a chance to add this back.

I'm reopening, but only for a suitable resolution.  The underlying cause indeed
seems to be UTF-8, but the suggested workaround (PERLIO setting) didn't work. 

Turns out RH8 sets the LANG by default (for US locale) to en_US.UTF-8. Changing
LANG to the setting from previous versions (en_US.iso885915) makes the install
work correctly.

Comment 3 Warren Togami 2005-05-28 07:24:38 UTC
Closing due to lack of activity and likely fixed in modern perl.  If this is
still an issue in RHEL4, FC3 or FC4 please open a new bug with new test
information and exact versions of packages.


Note You need to log in before you can comment on or make changes to this bug.