Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82139 - am not able to print
Summary: am not able to print
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-print
Version: phoebe
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-18 00:17 UTC by louisgtwo
Modified: 2015-01-08 00:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 09:59:11 UTC


Attachments (Terms of Use)

Description louisgtwo 2003-01-18 00:17:20 UTC
I have upgraded cups and redhat-config-printer from rawhide and set my
printer spool with it. I went to print with gedit and evolution but
nothing.
 
#lpq shows
 
hp2250 is ready
no entries
 
/etc/printcap shows only

hp2250:

should their be more stuff here? Also, /var/spool/lpd is empty and
/var/spool/cups has tmp which is empty also. I am printing to a remote (LPD)
printer.

This is my first time using cups, rh8 had LPRng which worked.

Comment 1 Tim Waugh 2003-01-18 17:50:26 UTC
Did the test page from redhat-config-printer work?

Comment 2 louisgtwo 2003-01-18 22:49:47 UTC
Yes, I'm able to print a test page. So I now think this is a
gnome-print/libgnomeprint bug. I will wait for the next beta to come out before
making anymore comments.

Comment 3 Tim Waugh 2003-01-18 23:20:15 UTC
What gnome-print version do you have?

Comment 4 louisgtwo 2003-01-18 23:30:34 UTC
gnome-print-0.35-9/libgnomeprint22-2.1.8-2

Can not print from evolution or gedit

Comment 5 Tim Waugh 2003-01-18 23:47:41 UTC
Please try printing to file and doing 'lpr file'.  Or view the file with ghostview.

Comment 6 louisgtwo 2003-01-19 00:26:42 UTC
Yes, I'm able to print to a file from both evolution and gedit. I can view both
outputs with ggv. I can print them by doing 'lpr file'. So somehow gnome-print
is not sending the job to the print spool.

Comment 7 Owen Taylor 2003-01-20 16:49:29 UTC
Hmmm, so far in testing I get very different results from 
evolution/gnome-print-0.37 and gedit/libgnomeprint22

 gnome-print: output disappears without a trace
 libgnomeprint22: get a huge (20+ meg) output file queued up, that
   takes a long time to print (haven't tried waiting for the output)



Comment 8 Owen Taylor 2003-01-20 18:04:42 UTC
For the evolution case, it turned out to be misconfiguration my 
test machine; after fixing that, printing from evolution worked fine.
So, I'm not sure what to say there.

Comment 9 louisgtwo 2003-01-21 03:07:20 UTC
After installing phoebe2 I'm able to print from evolution and gedit. Their is a
font problem printing from gedit. The font is not the same as in gedit. I'm
working on a stock phoebe2 with no rawhide packaged.

Comment 10 Tim Waugh 2003-01-21 09:59:11 UTC
That's a separate bug (which has already been filed).


Note You need to log in before you can comment on or make changes to this bug.