Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82135 - util-linux srpm needs, but doesn't BuildRequire, slang-devel
Summary: util-linux srpm needs, but doesn't BuildRequire, slang-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-17 22:38 UTC by Ed Blackman
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-29 13:40:35 UTC


Attachments (Terms of Use)

Description Ed Blackman 2003-01-17 22:38:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030117

Description of problem:
When rebuilding (rpm -ba --target i486-linux) the 8.0 util-linux package, I got
this message:

cc -c -O2 -march=i486 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I../lib -Wall
-Wmissing-prototypes -Wstrict-prototypes -I/usr/include/ncurses -DNCH=0
-I/usr/include/slang -D_FILE_OFFSET_BITS=64 -DSBINDIR=\"/sbin\"
-DUSRSBINDIR=\"/usr/sbin\" -DLOGDIR=\"/var/log\" -DVARPATH=\"/var\"
-DLOCALEDIR=\"/usr/share/locale\" -O2 -march=i486 -DSLCURSES=1 cfdisk.c -o cfdisk.o
cfdisk.c:66:24: slcurses.h: No such file or directory
make[1]: *** [cfdisk.o] Error 1
make[1]: Leaving directory `/home/bob/rpmroot/BUILD/util-linux-2.11r/fdisk'
make: *** [all] Error 1

The changelog note for 2.11n-19 says, in part, "- Package has no runtime deps on
slang, so remove the BuildRequires: slang-devel", which doesn't make much sense
to me.  BuildRequires specifies compile-time dependencies.

Installing the slang-devel package allowed me to successfully build util-linux
from the SRPM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Ensure slang-devel package isn't installed.
2. Attempt to rebuild util-linux-2.11r-10.src.rpm
    

Additional info:

Comment 1 Elliot Lee 2003-01-29 13:40:35 UTC
The dep is in the current rawhide package, and seems to have been since 2002-10-17


Note You need to log in before you can comment on or make changes to this bug.