Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82096 - bad settings for Greek on console
Summary: bad settings for Greek on console
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-17 14:06 UTC by Nikos Charonitakis
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-04 13:33:44 UTC


Attachments (Terms of Use)
Greek on console with font iso07u-16 (filename shown in screenshot) (deleted)
2003-02-20 17:40 UTC, Need Real Name
no flags Details

Description Nikos Charonitakis 2003-01-17 14:06:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; el-gr; rv:1.0.1) Gecko/20021003

Description of problem:
maybe this is relative to anaconda but i think
i can mention it here
when i choose greek language in installer or here
/etc/sysconfig/i18n contains this:

SYSFONT="latarcyrheb-sun16"

these fonts cant display greek messages in console
so we get boxes instead of greek fonts.
I noticed that rh linux ships with greek console fonts
so maybe another font have to take the place of the 
latarcyheb as the default font for greek lang.

Also in console the greek kbd is chosen by default but 
i dont know how can i write greek. May be there is a need of 
a defintion of a contol key that reverts latin to greek and greek to latin


At last in X windows greek keyboard is well configured
except that the user have to add in XF86Config this
 Option      "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll
in order to be usable


So I ask all these things that make greek fonts and kbd in console
and greek kbd in x-windows to work out of the box :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install redhat linux 8.0 with support of greek language
2.
3.
    

Actual Results:  problems (mostly in console)

Expected Results:  work out of the box

Additional info:

Comment 1 Brent Fox 2003-02-07 04:35:30 UTC
I don't think that Greek is one of the available languages in the installer. 
Are you sure that you chose Greek language and not Greek keyboard?  

Comment 2 Brent Fox 2003-02-07 04:40:15 UTC
I have modified the keyboard list in keyboard_models.py to say:

'gr'   : [_('Greek'), 'el,us', 'pc105', '', 'grp:ctrl_shift_toggle' ],

This should make sure that grp:ctrl_shift_toggle gets set.  I think that this
should take care of the X windows part of your request.

What does the grp_led:scroll option do?



Comment 3 Brent Fox 2003-02-07 04:57:30 UTC
Also, can you tell me what the SYSFONT in /etc/sysconfig/i18n should be set to
for Greek?

Comment 4 Nikos Charonitakis 2003-02-07 13:36:04 UTC
1) Greek is available in additional languages step of installation process.
So after installation you can choose greek as default system language(you have
to install some compatible with greek fonts before you do that)

2) What does the grp_led:scroll option do? 
it lights scroll lock led when you press Ctrl+Shift and indicates that you can
write greek
if you press again the combination you return to latin character set and light
goes out from Scroll lock
lead...

3) i ll reply about this (SYSFONT) later

Comment 5 Steve Stavropoulos 2003-02-08 02:54:30 UTC
 ctrl-shift is a bad compination for switching between languages. Many
applications use it (most notably gnome-terminal) so it can't be used for
something like that. A good choice would be alt-shift as it seems to be used by
most people in Greece and I haven't yet found an app that needs it.
 That means that grp:ctrl_shift_toggle should rather be grp:alt_shift_toggle. The   
grp_led:scroll is also a very usefull addition.

 The 'gr'   : [_('Greek'), 'el,us', 'pc105', '', 'grp:ctrl_shift_toggle' ], will
do the trick even if greek is just selected as second language, right?


Comment 6 Brent Fox 2003-02-12 19:00:42 UTC
Steve: As some users reported in another bug report, ctrl-shift is a bad
combination.  Yesterday I updated rhpl to use "grp:shift_toggle" to switch the
keymaps.  So pressing both Shift keys at the same time should switch the keymaps.

I'm going to change the component of this report to "rhpl" since that's where
the list of keyboards comes from.  

Comment 7 Brent Fox 2003-02-12 19:05:03 UTC
frolix: this was kind of two bug reports in one.  I think that I've fixed the
keyboard component of this bug with rhpl-0.92-1.  Please open a new bug against
redhat-config-language if you can tell me what the contents of
/etc/sysconfig/i18n needs to look like in order to handle Greek properly.

Actually, I'm not even sure that we have the proper console character sets to
print Greek fonts on the console.

QA, please verify that the latest rhpl writes out an XF86Config file that loads
both Greek and US keymaps and that pressing both Shift buttons allows you to
switch between them.  The Scroll Lock light on the keyboard should signify that
the toggle has happened.

Comment 8 Need Real Name 2003-02-20 17:40:58 UTC
Created attachment 90219 [details]
Greek on console with font iso07u-16 (filename shown in screenshot)

This is the font that I personally see suitable for displaying Greek on the
console.

Comment 9 Need Real Name 2003-02-20 17:42:55 UTC
All the following are for Greek on Console, not X11.

A. There are proper Greek fonts already in Red Hat Linux (8.0), in the package
kbd.

For example: {/lib/kbd/consolefonts/}iso07u-16.psfu.gz

B. The choice for switching between English and Greek is different between
individuals, typically based on what they learnt in earlier packages.
My favorite is Alt-Shift (both left buttons) as it is already used by default.
'loadkeys gr' does this.

Check attachment to see how the above font looks like.

Comment 10 Simos Xenitellis 2003-02-20 17:50:09 UTC
I used earlier my obsolete account. I can be contacted at this e-mail.

Simos Xenitellis

Comment 11 Nikos Charonitakis 2003-02-22 17:49:05 UTC
Brent
verified in phobe 2 (mixed with several updates of phoebe3)
It works but by default comes in greek character map. 
This may confuse some users that they dont know that shift+shift
is needed in order to  switch to english character map,
So i suggest to change if it is possible the default setting to :
default english map and
by pressing shift+shift to switch to Greek map.

Comment 12 Nikos Charonitakis 2003-02-22 18:30:26 UTC
(shift+shift) in my previous post 
i mean  left shift + right shift

Comment 13 Nikos Charonitakis 2003-08-04 13:33:44 UTC
-the issue is for xkb and greek settings is (partially) resolved
-the issue that arized from this fix is described here:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100773

For default greek console fonts and console settings
i will open a new bug for severn(beta1)


Note You need to log in before you can comment on or make changes to this bug.