Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 820941 - (rhq.plugins.www.util.WWWUtils)- Ping request returned a response with client error 403, but server returns 200
Summary: (rhq.plugins.www.util.WWWUtils)- Ping request returned a response with client...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-11 11:46 UTC by Libor Zoubek
Modified: 2015-11-02 00:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-14 22:00:58 UTC


Attachments (Terms of Use)

Description Libor Zoubek 2012-05-11 11:46:36 UTC
Description of problem: I am getting warnings from apache plugin in agent.log 

[ResourceContainer.invoker.daemon-58] (rhq.plugins.www.util.WWWUtils)- Ping request to [http://1.2.3.4:80] returned a response with client error 403 (Forbidden)

When I try GET on http://1.2.3.4:80 I get 200-OK.

Version-Release number of selected component (if applicable):
RHQ 4.5-master

How reproducible:always


Steps to Reproduce:
1.import apache on linux
2.check agent.log


Expected results: warnings should disappear, since  http://1.2.3.4:80 does not return 403

Comment 1 Larry O'Leary 2012-05-14 14:53:41 UTC
Is a redirect being used? What does the following produce:

wget --max-redirect=0 http://1.2.3.4/


I am not sure if we would handle redirects. Additionally, if a proxy configuration is used, it could react differently to each client. How are you testing the http://1.2.3.4:80 URL when receiving the 200 OK? Also, what does the access.log and error.log reveal for the ping?

Comment 2 Libor Zoubek 2012-05-14 22:00:58 UTC
Not a bug. My mistake. There is no proxy, no such thing. I just tried it in chromium and saw 'Red Hat Enterprise Linux Test Page' and I did not believe that by default httpd on RHEL6 returns 403.


Note You need to log in before you can comment on or make changes to this bug.