Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82087 - SRPMS: portability: 'inline' keyword is used as identifier
Summary: SRPMS: portability: 'inline' keyword is used as identifier
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: evolution
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-17 12:05 UTC by Sysoltsev Slawa
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-17 16:04:03 UTC


Attachments (Terms of Use)
Patch which fixes described BUG (deleted)
2003-01-17 12:07 UTC, Sysoltsev Slawa
no flags Details | Diff

Description Sysoltsev Slawa 2003-01-17 12:05:45 UTC
Description of problem:
in sources in file evolution-1.0.8/mail/mail-callbacks.h:121 is line:
void forward_messages      (CamelFolder *folder, GPtrArray *uids, gboolean inline);

If you supposed 'inline' here as identifier it is restricted by C compiler as 'inline' is 
the keyword (see clause 6.4.1 of C standards, paragraph 1). According paragraph 
2, clause 6.4.1 of C standards you can't use identifiers that are recognized by C 
compiler as keywords.

GNU C compiler doesn't emit the error because bug in compiler or maybe 
undocumented feature ( I mean inline parameters, as ridiculous it wouldn't sound. 
However I haven't found documentation on it). Seems it treats 'gboolean inline' 
as '<type> <modifier>', i.e. as declaration without parameter name. You can 
ensure in it adding any identifier name i.e. something like 'gboolean inline 
somename'; it won't expose error too with gcc.

I've never heard about inline parameters, so I suppose you just used invalid name 
for parameter. To be correct (and therefore increase Linux portability) you should 
another identifier in this declaration.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. I'm afraid the error cannot be shown with GNU C compiler.

    
Actual results:
Compilation errors with custom compiler.

Expected results:
Successfully built package.

Additional info:

Comment 1 Sysoltsev Slawa 2003-01-17 12:07:06 UTC
Created attachment 89421 [details]
Patch which fixes described BUG

Comment 2 Jeremy Katz 2003-01-17 16:04:03 UTC
We don't support recompiling with compilers other than the one we ship with.  
You might report the bug upstream at http://bugzilla.ximian.com and they may
care more about non-gcc compilers.


Note You need to log in before you can comment on or make changes to this bug.