Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82079 - USB Mass storage no longer works with Phoebe
Summary: USB Mass storage no longer works with Phoebe
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-17 05:44 UTC by redhat admin
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-17 15:27:10 UTC


Attachments (Terms of Use)

Description redhat admin 2003-01-17 05:44:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
I had an 8.0 box running the updated kernel (2.4.18-18.8.0) and my sony digital
camera worked beautifully with USB. It used to show up as /dev/sda, and I could
access /dev/sda1 as the memory stick. I decided to uprgade to the beta and my
camera is no longer detected, there are no messages in dmesg to state why

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try using a digital camera with usb mass storage
2.
3.
    

Actual Results:  The device is not detected with 2.4.20-2 as shipped with phoebe.

Expected Results:  As per 2.4.18

Additional info:

I installed the 2.4.18-18.8.0 kernel from rpm and booted from it and it works again.

Comment 1 Bill Nottingham 2003-01-17 05:58:20 UTC
Does this work better with the kernel from rawhide?

Comment 2 Nathan G. Grennan 2003-01-18 14:44:15 UTC
I am running kernel-2.4.20-2.21 and usb mass storage works fine.

Comment 3 Pete Zaitcev 2003-01-20 16:30:35 UTC
The bad news is that Phoebe went out with a completely broken USB.
Anything that is connected on the fly is not hot-plugged.
The good news is that it was only a beta, and we actually fixed it.
Should work in the next beta or -RC.



Comment 4 Pete Zaitcev 2003-02-03 21:37:04 UTC
Does the Phoebe2 (beta4) work?


Comment 5 redhat admin 2003-02-06 03:58:28 UTC
Is there a new beta ?

Comment 6 Pete Zaitcev 2003-02-06 06:13:19 UTC
It is still in the "phoebe" directory. We call it "Phoebe 2".
From my P.O.V., the main difference is working USB. :-)


Comment 7 redhat admin 2003-02-07 01:10:48 UTC
At ftp.redhat.com ?


what date was the new beta released and what date are there ISO images ? 

Comment 8 redhat admin 2003-02-17 02:31:14 UTC
I used the kernel from that newer beta (2.4.20-2.21) and USB works perfectly
with my camera.

Off topic : When is 8.1 slated for release ?

Comment 9 Pete Zaitcev 2003-02-17 15:27:10 UTC
We never announce releases as a matter of policy.



Note You need to log in before you can comment on or make changes to this bug.