Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82060 - rpm does not preserve modified binaries when upgrading packages
Summary: rpm does not preserve modified binaries when upgrading packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 23:52 UTC by Ben Elliston
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-17 14:37:52 UTC


Attachments (Terms of Use)

Description Ben Elliston 2003-01-16 23:52:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
I had Amanda installed on a 7.3 system and had replaced its /usr/lib/amanda/taper program with a locally modified version.  I had expected that when upgrading to RHL 8.0, that rpm would have either skipped upgrading that package because it contains a modified binary (whose checksum does not match the installed version) or at least moved it to a .rpmsave file.  Instead, RPM upgraded Amanda and overwrite the modified binary.

Shouldn't RPM be a little friendlier in this circumstance?

B.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a package.
2. Change a binary managed by the package (say, in /usr/bin).
3. Upgrade that package.  Notice that the modified binary is lost.
    

Actual Results:  The modified binary is overwritten with the corresponding one from the new package.

Expected Results:  The modified binary should have been renamed.

Additional info:

Comment 1 Jeff Johnson 2003-01-17 14:37:52 UTC
rpm does package, not file, management. That means that
files are installed from packages.

If you want to preserve your own binaries, then
uninstall the package before building your own
amanda from sources.


Note You need to log in before you can comment on or make changes to this bug.