Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82047 - Unhandled Exception in Installer
Summary: Unhandled Exception in Installer
Keywords:
Status: CLOSED DUPLICATE of bug 76123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-16 19:46 UTC by Need Real Name
Modified: 2006-02-21 18:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:12 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-16 19:46:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (Win98; I)

Description of problem:
On preparing to install screen (see 3.28 in installation guide), an unhandled exception occured when
next was selected.
See Below:

Exception Occured

An unhandled Exception has occured. This is most likely a bug.
Please copy the full text of this exception or save the crash dump
to a floppy then file a detailed bug report against anaconda at http://
bugzilla.redhat.com/bugzilla/

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py",line 786, in handleRenderCallback
     self.currentWindow.renderCallback()
  File "usr/lib/anaconda/iw/progess_gui.py", line 149, in renderCallback
     self.intf.icw.nextClicked()
  File "usr/lib/anaconda/gui.py", line 632, in nextClicked
     self.dispatch.gotoNext()
  File "usr/lib/anaconda/dispatch.py", line 150, in gotoNext
     self.moveStep()
  File "usr/lib/anaconda/dispatch.py", line 215, in moveStep
     rc = apply(func,self.bindArgs(args))
  File "usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
     partitions.doMetaDeletes(diskset)
  File "usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
     lvm.vgactivate()
  File "usr/lib/anaconda/lvm.py", line 54, in vgactivate
     searchPath = 1)
  File "usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
     childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD
2. Select Automatic Partitioning
3. Remove all partitions on system
4. Network Configuration use DHCP
5. firewall Config. Medium
6. Setup 2 user accounts
7. Package Group Selection, select all.
    (Tried with fewer packages, got same error)

    

Actual Results:  Same error

Expected Results:  ?

Additional info

Comment 1 Michael Fulbright 2003-01-16 20:27:56 UTC
How much RAM is in this system?

Comment 2 Michael Lee Yohe 2003-01-21 14:02:05 UTC
Reporter, check to see if your bug is a duplicate of Bug 76123.  There are
useful comments with regards to how much memory must be installed in your
machine to install Red Hat Linux 8.0.

Comment 3 Need Real Name 2003-01-21 14:50:44 UTC

*** This bug has been marked as a duplicate of 76123 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.